Menu

RechercheV ne marche pas mais je ne vois pas pourquoi (#NA) [Résolu]

TOT127 898 Messages postés mercredi 8 avril 2009Date d'inscription 7 mai 2018 Dernière intervention - 8 juil. 2017 à 11:48 - Dernière réponse : TOT127 898 Messages postés mercredi 8 avril 2009Date d'inscription 7 mai 2018 Dernière intervention
- 11 juil. 2017 à 12:43
Coucou,
dans ce fichier, il me semble ne pas avoir fait d'erreurs avec la formule RechercheV (feuille "All"), et pourtant j'obtiens une erreur. Ca ne m'est jamais arrivé, enfin ça m'arrivait quand je ne savais pas faire de RechercheV
http://www.cjoint.com/c/GGijV7Tl1LY
Le fichier contient des macros apparement, est ce le prb?
merci!
Afficher la suite 

Votre réponse

3 réponses

PapyLuc51 1518 Messages postés dimanche 3 mai 2009Date d'inscription 19 juin 2018 Dernière intervention - 11 juil. 2017 à 07:10
0
Merci
Bonjour

1/ A ma première réponse je n'avais pas été plus loin que la cellule B2 de "All" mais en complétant tout la colonne les cellules qui n'ont pas de correspondance chiffrée donnent #N/A. J'ai donc ajouter la condition SIERREUR() à la formule précédemment donnée.

=SIERREUR(RECHERCHEV($A2;'2009'!$B:$C;2;FAUX);"")

2/ J'ai aussi complété les calculs dans "All" et j'ai remarqué quelques anomalies dues à l'ajout d'un espace après certains noms dans la colonnes B de tous les feuillets. Pour éviter ce genre de problème il serait bon d'installer sur les futurs ajouts de feuillets une liste déroulante basée sur la colonne B de "All".

Ton fichier ainsi complété en retour

http://www.cjoint.com/c/GGlfjKImzJv

Cordialement
TOT127 898 Messages postés mercredi 8 avril 2009Date d'inscription 7 mai 2018 Dernière intervention - 11 juil. 2017 à 12:43
merci, je regarde ça
Commenter la réponse de PapyLuc51
PapyLuc51 1518 Messages postés dimanche 3 mai 2009Date d'inscription 19 juin 2018 Dernière intervention - 8 juil. 2017 à 12:22
-1
Merci
Bonjour,

La zone de recherche doit être B:C car le nom recherché est dans la colonne B

la formule pour B2 du feuillet All est

=RECHERCHEV(A2;'2009'!B:C;2;FAUX)

Cordialement
Commenter la réponse de PapyLuc51