Nagios sous Debian [Résolu/Fermé]

Signaler
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
-
mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
-
Bonsoir,

J'ai virtualisé Nagios sous Debian dans un ESXi en suivant ce tuto :
https://blog.jolos.fr/2015/09/installer-nagios-4-sur-debian-8/

Je ne comprends rien quand j'arrive à cette étape :
https://blog.jolos.fr/2015/12/installer-le-sdk-de-vsphere-sur-debian-8-jessie/

Si quelqu'un passe par là et a déjà fait ça, son aide est la bienvenue.

Merci beaucoup.

1 réponse

Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 805
Bonjour,

Nagios n'est pas ma spécialité mais en gros voici ce que ça raconte.

Pour vérifier l'installation de nagios, un certain nombre de scripts écrits en perl sont mis à disposition (les commandes
check_vmware_*
). Toutefois, pour pouvoir s'exécuter, ces programmes requièrent d'installer au préalable une couche logicielle appelée SDK. La commande
aptitude install libnagios-object-perl libnagios-plugin-perl perl-doc
permet d'installer ledit SDK.

Il faut ensuite récupérer le script d'installation
vmware-install.pl
.

Malheureusement, l'auteur explique que VMWare n'a pas prévu de traiter le cas de debian dans son SDK, ce qui oblige à modifier légèrement le script
vmware-install.pl
. Il faut donc, avec un éditeur texte (par exemple gedit) corrigé ce fichier comme indiqué par l'auteur.

Ceci fait il faut bidouiller un peu
perl
car visiblement le script fourni par vmware ne marche pas avec les versions récente de perl. C'est ce que permet de faire la commande
cpan
.

Une fois ces étapes effectuées, l'auteur conclue en disant que le script d'installation devrait désormais être exécutable.

Bonne chance
Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
12
Bonsoir,

Merci pour cette explication. Je ne me suis pas aventurée à manipuler le script ni perl mais j'ai essayé un autre tuto et cette fois, Nagios semble bien installé mais n'envoie pas de mails... En tout cas, merci beaucoup pour cette explication. Je m'y essaierai dès que j'aurais résolu ce problème de mails d'alerte. On ne sait jamais si j'y arrive.
mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 805
Merci pour ton retour, n'hésite pas à indiquer dans ce fil de discussion un lien vers le tutoriel que tu as utilisé, ça pourrait aider les gens qui tombe sur ce fil de discussion.
Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
12 > mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020

Voici ce que j'ai trouvé et utilisé et ça marche : https://wiki.monitoring-fr.org/nagios/start#nagios
mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 805
Merci pour ton retour :-)