Menu

Formule OU [Résolu]

pat - 20 juin 2017 à 08:44 - Dernière réponse : Vaucluse 21879 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention
- 21 juin 2017 à 07:57
Bonjour,

J''ai une formule qui fonctionne aprfaitement, cependant j'aimerais ajouter une fonction " OU ".
Voici la formule de base :
=SI(LIGNES(Feuil1!$1:1)>NB.SI(Feuil1!D$1:D$30;S$1);"";INDEX(Feuil1!A$1:A$30;EQUIV(S$1;Feuil1!D$1:D$30;0)+LIGNES(Feuil1!$1:1)-1))

Je souhaiterais donc pouvoir placer le "OU" sur les parties en gras
donc OU S1 ; S2 ; S3 ; S4 ; S5

Merci d'avance pour votre aide


Afficher la suite 

5 réponses

Répondre au sujet
Vaucluse 21879 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 20 juin 2017 à 09:17
0
Utile
Bonjour
votre formule demande quelques explications
par exemple
1°) quel est le but de LIGNES($1:1) qui renvoie 1 sur la 1°; ligne de la formule?
2°) que se passe t il si D1:D30 contiennent plusieurs code inscrit en S1:S5, sachant que EQUIV ne renverra jamais que le 1° trouvé?
..bref, quel sont vos arguments à mettre en place
à vous lire
crdlmnt

Commenter la réponse de Vaucluse
0
Utile
1
Il est peut être possible de faire plus simple, cependant le but de la formule est simplement de véririer si :
sur la feuille1 en colone D si la valeur texte correspond a soit feuille2 S1 ou S2 ou S3 ou S4 ou S5 si c'est le cas, copier coller La valeur inscrite en colone A qui se trouve sur la même ligne.

Pouvoir étirer cette formule vers le bas
il est bien sur possible qu'il y aie plusieurs fois des valeur identique en colonne D

Si mes informations ne sont pas suffisament clair n'hésitez pas a me le faire savoir

Encore merci
Vaucluse 21879 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 20 juin 2017 à 11:14
Alors je vous propose cette formule à adapter pour:
  • des références en S1:S5
  • à chercher dans le champ D1:D30
  • pour ressortir la valeur correspondante en A1:A30

=SIERREUR(INDEX($A$1:$A$30;PETITE.VALEUR(SI(NB.SI($S$1:$S$5;$D$1:$D$30);LIGNE($A$1:$A$30));LIGNE(A1)));"")

attention. Cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle s'affiche automatiquement entre accolades dans la barre des tâches.
Ca donne ça pour info
http://www.cjoint.com/c/GFujn2TN4NC

crdlmnt
Commenter la réponse de pat
0
Utile
1
Serieusement j'ai du mal a comprendre cette formule mais elle fonctionne parfaitement alors il me reste simplement a dire un grand merci!!!!

Merci
Vaucluse 21879 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 21 juin 2017 à 07:57
C''est l'essentiel
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de pat