Menu

Determiner combien de clients ont été fidèles depuis un fichier [Résolu]

SECER2 11 Messages postés dimanche 30 avril 2017Date d'inscription 14 juin 2017 Dernière intervention - 14 juin 2017 à 14:23 - Dernière réponse :  SECER2
- 16 juin 2017 à 08:51
Bonjour,

Comment trouver une formule pour déterminer combien de clients ont été fidèles depuis un fichier EXCEL.
D'après mes critères:
ENTREPRISES PARTANTES *
ENTREPRISES ENTRANTES **
AUTRES***
entreprises fidèles.

Merci à vous.
Afficher la suite 

8 réponses

Répondre au sujet
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 14 juin 2017 à 14:29
0
Utile
Bonjour
vous pouvez nous en dire plus?
quelle est exactement l'info placée dans quelle colonne pour chaque entreprise (le texte ou uniquement les *?)

en attendant pour compter chaque catégorie s'il s'agit de * ou** ou***
par exemple de A1àA100

=SOMMEPROD((A1:A100="*")*1)
=SOMMEPROD((A1:A100="**")*1)
etc..

à vous lire

crdlmnt

Commenter la réponse de Vaucluse
SECER2 11 Messages postés dimanche 30 avril 2017Date d'inscription 14 juin 2017 Dernière intervention - 14 juin 2017 à 14:36
0
Utile
4
par exemple:
J'ai des entreprises qui ont versées une somme mais pas régulièrement.
j' ai fait une colonne A: entreprise, et puis colonne B 2012, C 2013, D, E et F 2016.
Mon tableau récap va déterminé en déterminant mes critères ( 2dernières années somme versée donc entreprise entrante, 2 dernières années non versées donc entreprises partante)
et puis celles qui on été régulières ca sera toutes les colonnes de B à F et les autres qui ne rentrent dans aucune case.

ca vous parle!
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 14 juin 2017 à 14:53
Vaguement

on va essayez, si ça ne va pas mettez un fichier à disposition en bidonnant les noms sur:
http://www.cjoint.com
et revenez ici coller le lien donné par le site

en attendant pour un champ de A2 à F28:
entreprise partante:
=SOMMEPROD((B2:B28<>"")*(C2:C28<>"")*(D2:D28<>"")*(E2:E28="")*(F2:F28=""))
attention , ne compte que si les deux dernières années sont vides

entreprise entrante:
=SOMMEPROD((B2:B28="")*(C2:C28="")*(D2:D28="")*(E2:E28<>"")*(F2:F28<>""))
ne compte que si les deux dernières années sont pleines

entreprise fidèle:
=SOMMEPROD((B2:B28<>"")*(C2:C28<>"")*(D2:D28<>"")*(E2:E28<>"")*(F2:F28<>""))

autres:
=NB.VAL(A2:A28)-SOMME(cell précédentes)

Nota 1:utilisez bien les N° d elignespour les limites de champ ( pas de A:Aou B:B, avec SOMMEPROD ça devient assez vite lourd)

Nota 2: si vous affectez des valeurs numériques dans les colonnes B à F, mieux vaut remplacer le <>"" par >0 et le"" par =0
à vous lire si besoin

crdlmnt
SECER2 11 Messages postés dimanche 30 avril 2017Date d'inscription 14 juin 2017 Dernière intervention - 14 juin 2017 à 15:30
http://www.cjoint.com/c/GFonDZGD8w5


Ca vous va ce fichier? merci pour le conseil.

Bien crdlmnt
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 14 juin 2017 à 16:08
le fichier oui ça devrait aller, mais deux questions
1°)quelle est la différence entre les cellules vides et les cellules affichant un 0
2°) avez vous testé les formules proposées dans mon précédent message, en utilisant>0 à la place de <>""
je reviens fin de PM
crdlmnt
SECER2 11 Messages postés dimanche 30 avril 2017Date d'inscription 14 juin 2017 Dernière intervention > Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 14 juin 2017 à 16:33
sommeprod(B2:B692;">0")*(C2:C692;">0")&(D2:D692;">0")*(E2:E692;"=0")*(F2:F692;"=0").
ca donne rien.

SOMMEPROD(B2:B692 >0)*(C2:C692>0)&(D2:D692>0)*(E2:E692=0)*(F2:F692=0)

ca m'affiche des 0. même quand il y a une case avec un montant
Commenter la réponse de SECER2
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 14 juin 2017 à 18:27
0
Utile
1
C'est effectivement un peu plus compliqué car les colonnes dates ne sont pas toutes remplies et le code SOMMEPROD ne fonctionne donc pas correctement
je peux "pour le moment" vous proposer ce modèle, avec une colonne K qui permet d'affecter le statut à chaque ligne pour les compter ensuite

http://www.cjoint.com/c/GFoqABQM3n0

je cherche s'il y a éventuellement une possibilité de formule plus directe

Notez en aparté que ce système pourrait permettre de mettre dans le tableau les lignes en couleur différentes selon leur statut
crdlmnt
Merci, vous m'avez aidé et c'est appréciable.
Je dois un jour à m'y mettre sérieusement sur Excel pour comprendre chaque fonction.

Je vous souhaite une bonne journée.
Amicalement
Secer
Commenter la réponse de Vaucluse