Menu

Moyenne de valeurs [Résolu]

Oscarge 1 Messages postés vendredi 9 juin 2017Date d'inscription 9 juin 2017 Dernière intervention - 9 juin 2017 à 17:05 - Dernière réponse :  oscarge
- 13 juin 2017 à 15:43
Bonjour,

dans le premier feuillet de mon tableur Excel, je voudrais faire la moyenne des valeurs rattachées à des références, contenues dans les feuillets suivants, je m’explique :

• Feuillet 1

Col. A / Col. B
101 / Moyenne des valeurs rattachées à 101 dans les autres feuillets
164 / Moyenne des valeurs rattachées à 164 dans les autres feuillets
408 / Moyenne des valeurs rattachées à 408 dans les autres feuillets
512 / Moyenne des valeurs rattachées à 512 dans les autres feuillets
530 / Moyenne des valeurs rattachées à 530 dans les autres feuillets

• Feuillet 2

Col. A / Col. B
101 / 14
408 / 6
530 / 26

• Feuillet 3

Col. A / Col. B
101 / 11
164 / 18
408 / 9
512 / 36

• Feuillet 4

Col. A / Col. B
164 / 20
408 / 8
512 / 32
530 / 25

En admettant que je n’ai que 3 feuillets (en plus du premier dans lequel doit figurer les moyennes), les résultats devraient être les suivants :

Cellule B1 du feuillet 1 = (14+11) /3 = 8.33
Cellule B2 du feuillet 1 = (18+20) /3 = 12.67
Cellule B3 du feuillet 1 = (6+9+8) /3 = 7.67
Cellule B4 du feuillet 1 = (36+32) /3 = 22.67
Cellule B5 du feuillet 1 = (26+25) /3 = 17

J’ai pensé à la fonction « RECHERCHER » combinée avec la fonction « SOMME » mais j’avoue n’avoir pas trouvé.

Merci de bien vouloir me venir en aide.

Oscarge
Afficher la suite 

Votre réponse

3 réponses

Vaucluse 22003 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - Modifié par Vaucluse le 9/06/2017 à 17:17
0
Utile
Bonjour
vous ne dites pas si vous pouvez avoir plusieurs fois le même code dans le même feuillet

dans les deux cas toutefois, ceci devrait fonctionner

=SOMME.SI(Feuil1!A:A;A1;B:B)+SOMME.SI(Feuil2!A:A;A1;B:B)+SOMME.SI(Feuil3!A:A;A1;B:B))/(NB.SI(Feuil1!A:A;A1)+NB.SI(Feuil2!A:A;A1)+NB.SI(Feuil3!A:A;A1))

attention aux parenthèses

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Raymond PENTIER 45852 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - 10 juin 2017 à 03:21
Oui, Vaucluse, "attention aux parenthèses", comme celle qui manque tout au début, après le signe = ...

Avec toutes mes amitiés.
oscarge > Raymond PENTIER 45852 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - 13 juin 2017 à 15:43
Avec un peu de retard, merci Vaucluse et Raymond pour ces recommandations qui m'ont permis de finaliser mon tableau.
Guillaume
Commenter la réponse de Vaucluse