Récupérer une valeur d'une autre feuille grace à un code. [Fermé]

- - Dernière réponse : ccm81
Messages postés
9175
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 novembre 2019
- 1 juin 2017 à 18:26
Bonjour,
Je souhaite récupérer une donnée d'une feuille Excel et l'envoyer sur une autre feuille en fonction du code attribué à la ligne.
Je m'explique avec un exemple car je ne dois pas être clair du tout.
Feuille 1 :

-----A-----B
1 -- 999 -- 256€
2 -- 987 -- 268€
3 -- 982 -- 275€
4 -- 966 -- 292€

Feuille 2
-----A----------B---------C
1 -- 982 -- alimenthight - ???

Voila en c1 je voudrais afficher automatiquement la valeur B3 (275) de la feuille 1.

Donc si le code de la colonne A de la feuille 1 est égale au code A de la feuille 2, alors afficher la donnée de la colonne B de la feuille 1 dans la colonne C de la feuille 2.

Est ce clair pour vous ?

Merci d'avance.
Cordialement
Afficher la suite 

7 réponses

Messages postés
9175
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 novembre 2019
1666
0
Merci
Bonjour

Un petit exemple avec RECHERCHEV
http://www.cjoint.com/c/GEFrJsY5NaH

Cdlmnt
0
Merci
Merci beaucoup pour avoir prix le temps de répondre :)

Par contre peux tu m'expliquer le =RECHERCHEV(A2;Feuil1!A:B;2;0)

A2 --> c'est mon code
Feuil1!A --> je le recherche dans la colonne A de la feuille 1
:B --> j'affiche la valeur de la colonne B correspondant au code de la colonne A

Et que signifie le 2 et le 0 ?

merci d'avance
0
Merci
=RECHERCHEV(A22;Feuil27!A:G;2;0)

J'ai tapé cette formule car je recherche la donnée affichée dans la colonne G et non la colonne B.

Mais pas de chance il m'affiche la donnée de la colonne B ...
j'imagine que c'est du au code derrière ?

Merci
Messages postés
16002
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
5 décembre 2019
2833
0
Merci
Bonjour Jesoin, CCM81

ca va, ccm81 ? :o)
comme je passais dans le coin

Il ya beaucoup de techniques expliquées dans la rubrique "Astuces" du forum
concernant recherchev
http://www.commentcamarche.net/faq/s/recherchev
Messages postés
9175
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 novembre 2019
1666
0
Merci
Bonjour

Je complète sur la bête au cas où le lien de michel (salut cordial à toi) te noierait dans la foule d'informations.
=RECHERCHEV(A22;Feuil27!A:G;2;0)
1. Le 2 dans la formule indique que la valeur renvoyée est dans la 2° colonne de la plage indiquée (ici A:G) donc ... B
Si tu veux que la valeur renvoyée soit prise dans la colonne G tu mets ... 7
2. Le 0 indique que la recherche se fait sur la valeur exacte
RQ. La valeur cherchée (ici A22) est obligatoirement cherchée dans la première colonne de la plage (ici A)

Cdlmnt
0
Merci
Re,
Bon ça fonctionne ce qui est déjà une très bonne chose je t'en remercie :)
Par contre j'ai une chose que je ne comprend pas :

=RECHERCHEV(A22;Feuil27!A:G;7;0)
Dans cette formule qui fonctionne, pourquoi la plage est A:G et pas tout simplement =RECHERCHEV(A22;Feuil27!A;7;0) ?

Puisque la donnée que je veux retrouver se situe dans la 7ème colonne de la feuille 27 dont le code de la première colonne est identique au code que ma cellule A22 ?

Merci d'avance si vous pouvez me comprendre sinon ce n'est rien si cela fonctionne c'est déjà très bien :)
Messages postés
9175
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 novembre 2019
1666
0
Merci
La fonction RECHERCHEV(V ; plage ; C ; 0) cherche dans la première colonne de plage à nbL lignes et nbC colonnes (avec nbC >= C) la première occurrence de la valeur V et si elle la trouve à la ligne L, renvoie la valeur située à la ligne L et dans la colonne C de plage.
RQ. La plage ne commence pas forcément en colonne A, donc la colonne C de la formule est relative à la plage et non à la feuille

C'est comme ça que microsoft l'a définie (je te conseille de voir l'aide à ce sujet)

Cdlmnt