Menu

Comment visualiser(pas décrypter) 1 fichier texte chiffré Gnugp? [Résolu]

Nowanym-Vwayon 5 Messages postés dimanche 21 mai 2017Date d'inscription 22 mai 2017 Dernière intervention - 21 mai 2017 à 16:04 - Dernière réponse : Nowanym-Vwayon 5 Messages postés dimanche 21 mai 2017Date d'inscription 22 mai 2017 Dernière intervention
- 21 mai 2017 à 18:18
bonjour

Je suis entrain d'essayer de chiffrer un message avec Gnupg mais je n'arrive pas a le visualiser chiffré. J'ai essayé de plusieurs manières:

-sur le terminal:

1:

~$ cd Tor\[mon_fichier]
{enter} (ça écrit l'emplacement en bleu)

~$ gpg --armor --recipient [id destinataire] --output [nom_fichier_chiffrée] --encrypt [nom_fichier]

Il demande si il faut utilisé la clé normal vu que c'est une clé par sur, je dis oui {entrer} ; réponse:

~$ gpg: impossible d'ouvrir [nom_fichier] encryption failed

([mon_fichier] est écrit par moi dans une fenêtre gedit enregistrer sous mon_fichier: qu'est ce qui ne va pas?)

2:

~$ gpg -r [id destinataire] -sea [j'écris le message][/code]
{entrer} ; réponse:

~$ utilisation: gpg [options] [fichier]

(je comprends pas)

-En mode graphique:

click droit sur le fichier à chiffrer > je choisi la clé > création de [mon_fichier].pgp > tout va bien... > je veux l'ouvrir pour faire un copier/coller comme ton message chiffré en début de post mais ça donne pas du tout la même chose et gedit me dit: "un problème est apparu lors de l'ouverture du fichier > le fichier contient des caractères non-valides (entre nous je m'en rends bien compte plein de carré rouge avec des [/B0,/9C,/CD...etc et aussi quelques carré encadrés noir avec deux chiffres/lettres en haut et deux en bas (ceux la ils sont dans mes choix de police (pour le terminal par exemple)" v

J'ai encore essayé d'autre techniques/manips toujours soldées par un échec. mon but étant de pouvoir ouvrir un fichier chiffrée dans gedit apr exemple

PS: pour la config: est-il possible de modifier le fichier gpg.conf qui est écrit en anglais en rajoutant des lignes en français?

Dans https://www.nextinpact.com/news/102685- … rfaite.htm il propose de le faire, mais il ne renseigne pas si son fichier gpg.conf est en anglais ou en français

sinon comment le configurer?


Voilà,si vous avez des idées

merci
Afficher la suite 

4 réponses

Répondre au sujet
0
Utile
Bonjour,
https://doc.ubuntu-fr.org/gnupg
Commenter la réponse de jns55
Nowanym-Vwayon 5 Messages postés dimanche 21 mai 2017Date d'inscription 22 mai 2017 Dernière intervention - 21 mai 2017 à 17:28
0
Utile
gpg2 --armor --output "mon_fichier_chiffré" --encrypt "mon_fichier"

avec les guillemets?
Commenter la réponse de Nowanym-Vwayon
Nowanym-Vwayon 5 Messages postés dimanche 21 mai 2017Date d'inscription 22 mai 2017 Dernière intervention - Modifié par Nowanym-Vwayon le 21/05/2017 à 17:38
0
Utile
réponse: utilisation : gpg [options] [fichier]
peut-être, le fait d'être sur tails change quelque chose?
Commenter la réponse de Nowanym-Vwayon
Nowanym-Vwayon 5 Messages postés dimanche 21 mai 2017Date d'inscription 22 mai 2017 Dernière intervention - 21 mai 2017 à 18:18
0
Utile
j'ai trouvé

du coup la manip c'est:

d'abord:

~$ cd '/home/[le dossier où est le fichier à chiffré]'

Il faut bien regarder le chemin pour aller jusqu'au dossier où est stocker le fichier à chiffrer ( chacun a le sien propre ) et ne pas oublier les apostrophes qui encadre le tout.

tapez sur la touche entrer

normalement l'invite de commande (un $ souvent ) doit être précédé du chemin (en bleu pour moi mais peut-être celà dépend)

ensuite:(je prend en exemple ce qui se passe pour moi)

~/Persistent/Tor Browser$ gpg --armor --recipient [id destinataire] --output [fichier_chiffrer] --encrypt --armor [fichier]

ils faut bien sur remplacer ce qu'il y a entre crochet avec ce qu'il vous importe sans les crochets
Commenter la réponse de Nowanym-Vwayon