Menu

Addition de cellules sans doublon [Résolu/Fermé]

xeug 35 Messages postés jeudi 14 janvier 2016Date d'inscription 22 janvier 2018 Dernière intervention - 9 mai 2017 à 08:12 - Dernière réponse : xeug 35 Messages postés jeudi 14 janvier 2016Date d'inscription 22 janvier 2018 Dernière intervention
- 9 mai 2017 à 10:25
Bonjour,
Dans une colonne j'ai des n° de bon représentant des commandes.
10;11;12;12;13;14...
Le problème c'est que je peux avoir deux même n° de bon représentant des articles différents sur la même commande.
Je voudrais savoir le nombre de commande (dans l'exemple ci dessus 5 et non 6).
Merci.
Afficher la suite 

4 réponses

michel_m 15289 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - 9 mai 2017 à 08:18
0
Utile
Bonjour
le n° de commande dans A1:A30

=SOMMEPROD(1/NB.SI(A1:A30;A1:A30))
Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades : { formule }
Patrice33740 6837 Messages postés dimanche 13 juin 2010Date d'inscription 23 mai 2018 Dernière intervention - 9 mai 2017 à 08:37
Bonjour Michel,

Bien vu, mais le PROD n'est pas nécessaire :
=SOMME(1/NB.SI(A1:A30;A1:A30))
en matriciel fonctionne aussi.

Cdlt
Patrice
xeug 35 Messages postés jeudi 14 janvier 2016Date d'inscription 22 janvier 2018 Dernière intervention > Patrice33740 6837 Messages postés dimanche 13 juin 2010Date d'inscription 23 mai 2018 Dernière intervention - 9 mai 2017 à 10:25
Que de solutions...
Et cela fonctionne
Merci.
Patrice33740 6837 Messages postés dimanche 13 juin 2010Date d'inscription 23 mai 2018 Dernière intervention - 9 mai 2017 à 08:27
0
Utile
Bonjour,

Dans une autre colonne :
=NB.SI($A$1:$A1;A1)=1

à tirer vers le bas
Puis faire la somme de cette colonne