Menu

Formule excel [Fermé]

nanou72 - 21 avril 2017 à 18:02 - Dernière réponse : Mike-31 16091 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention
- 21 avril 2017 à 19:01
Bonjour,

je vous prie de bien vouloir m'aider svp car je bataille avec une formule qui ne marche pas du tout sur mon fichier :

- colonne A = 1ère date
- Colonne B = 2ème date
- colonne C = 3eme date

je dois vérifier si la 3ème date est comprise entre la 1ère date et la 2ème date si oui alors "Ok" si non alors "Out"

sauf que quand je mets cette formule :
= si(et(C1>=A1;C1<=B1);"ok";"out) ça ne marche pas et me met toujours "out" même si la date est bien comprise entre les 2 premières dates.

J'espère que j'étais claire en vous remerciant infiniment pour votre aide.

nanou72



Afficher la suite 

2 réponses

Hydr0s 1624 Messages postés lundi 24 janvier 2011Date d'inscription 15 avril 2018 Dernière intervention - 21 avril 2017 à 18:27
0
Utile
Salut,

Il faut vérifier plusieurs choses :
  • le format de tes dates. Elles sont normalement rentrées au format
    01/01/1990
    . Pour cela, tu peux regarder si excel a bien pris en compte la date ou non
  • la formule : il manque un " après le out mais excel aurait du te mettre un avertissement
    =SI(ET(C1>=A1;C1<=B1);"OK";"OUT")



Mike-31 16091 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - Modifié par Mike-31 le 21/04/2017 à 19:14
0
Utile
Bonsoir,

également à tester si tes valeurs sont mélangées dans les colonnes A et B
=SI(OU(NB.SI($A$2:$A$50;C2)>0;NB.SI($B$2:$B$50;C2)>0)=VRAI;"ok";"out")

et pour tester si colonne C est renseignée et éviter le out si la cellule en C est vide
=SI(C2="";"";SI(OU(NB.SI($A$2:$A$50;C2)>0;NB.SI($B$2:$B$50;C2)>0)=VRAI;"ok";"out"))
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.