Menu

Date [Résolu/Fermé]

xav55 3 Messages postés vendredi 25 avril 2014Date d'inscription 15 avril 2017 Dernière intervention - 15 avril 2017 à 10:00 - Dernière réponse :  xav55
- 16 avril 2017 à 21:26
Bonjour


Je recherche la formule me permettant cela: J'ai dans un cellule le mot "lundi" et je souhaite trouver la formule me donnant dans la cellule précédente le mot "dimanche"


merci de votre aide.
Afficher la suite 

12 réponses

Meilleure réponse
Mike-31 16134 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 15 avril 2017 à 11:51
1
Merci
Bonjour,

Si en A4 tu as non pas une date mais le jour en toute lettre, exemple dimanche et en A3 ou au dessous A5 tu veux le jour précédent ou suivant essaye comme cela

=TEXTE(INDEX({0;2;3;4;5;6;7;1};EQUIV(A5;{0;"lundi";"mardi";"mercredi";"jeudi";"vendredi";"samedi";"dimanche"};0))-1;"jjjj")

Merci Mike-31 1

a aidé 24700 internautes ce mois-ci

mdo100 116 Messages postés jeudi 9 décembre 2010Date d'inscription 21 mai 2018 Dernière intervention - 15 avril 2017 à 23:33
Bonsoir Mike-31,

Bien joué, j'avais pensé aussi utiliser la fonction "CHOISIR" mais je n'y suis pas parvenu.
Est-ce possible ?

Cdlt.
Meilleure réponse
Mike-31 16134 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 16 avril 2017 à 09:18
1
Merci
Re,

oui bien sur mais la formule sera plus longue
=TEXTE(CHOISIR(1+(A2="lundi")*(2)+(A2="mardi")*(3)+(A2="mercredi")*(4)+(A2="jeudi")*(5)+(A2="vendredi")*(6)+(A2="samedi")*(7)+(A2="dimanche");"";1;2;3;4;5;6;7)-1;"jjjj")

Merci Mike-31 1

a aidé 24700 internautes ce mois-ci

mdo100 116 Messages postés jeudi 9 décembre 2010Date d'inscription 21 mai 2018 Dernière intervention - 16 avril 2017 à 09:46
Re Mike-31,

Merci pour cette formule, je pensais au contraire qu'avec la fonction "CHOISIR" elle serait moins longue.
Donc je retiens personnellement celle que tu as proposé à xav55 au message #5.

Bon dimanche.
Cordialement.
xav55 > mdo100 116 Messages postés jeudi 9 décembre 2010Date d'inscription 21 mai 2018 Dernière intervention - 16 avril 2017 à 21:26
merci pour votre réponse.
Vaucluse 22048 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 15 avril 2017 à 10:06
0
Merci
Bonjour
en A1:

=SI(A1="lundi";"dimanche";"")
mais tout cela parait bien un peu simpliste?

si vous voulez plus déposez un fichier ici, avec une explication sur ls résultats attendus:
https://mon-partage.fr
et revenez coller ici le lien créé sur le site
crdlmnt


xav55 3 Messages postés vendredi 25 avril 2014Date d'inscription 15 avril 2017 Dernière intervention - 15 avril 2017 à 10:56
Merci pour votre réponse mais j'avais pensé à cette solution mais dans mon tableau les jour sont mélangés, il me faudrait une formule qui me permet de donner le jour -24h.

Merci encore
Vaucluse 22048 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 15 avril 2017 à 11:35
alors déposez le fichier comme proposé, parce que sans ça, on ne saura pas vous aider..
... et expliquez bien, parce que votre premier message ne dit pas grand chose de ce que vous voulez faire.
xav55 3 Messages postés vendredi 25 avril 2014Date d'inscription 15 avril 2017 Dernière intervention - 15 avril 2017 à 13:01
merci pour votre aide , voici le lien https://mon-partage.fr/f/8TZd7k9k/
mdo100 116 Messages postés jeudi 9 décembre 2010Date d'inscription 21 mai 2018 Dernière intervention - 15 avril 2017 à 11:47
0
Merci
Bonjour xav55, Vaucluse,

Comme le dit Vaucluse, avec un fichier ce serait mieux.

Toutefois si il y a une date dans la cellule "A1"= 10/04/2017 qui correspond à un lundi et que l'on veut dans "B1" le jour précédent le plus simple est:
=A1-1

ou encore:
=DATE(ANNEE(A1);MOIS(A1);JOUR(A1)-1)

Mais c'est pas sûr que c'est le résultat recherché.
Dans ce cas fournir un fichier.

Cordialement.
PHILOU10120 4974 Messages postés lundi 16 avril 2012Date d'inscription 25 mai 2018 Dernière intervention - 16 avril 2017 à 11:00
0
Merci
Bonjour

Avec la date en A1 par exemple

en B1 mettre cette formule

=CHOISIR(JOURSEM(A1;2);"Lundi";"Mardi";"Mercredi";"Jeudi";"Vendredi";"Samedi";"Dimanche")

Vous obtenez Dimanche pour la date de ce jour 16/04/2017

merci pour vos réponses ,grâce à vous j'ai résolu mon problème