Remplacer une partie de formule dans une cellule sous Excel [Fermé]

Messages postés
2
Date d'inscription
vendredi 14 avril 2017
Statut
Membre
Dernière intervention
15 avril 2017
- - Dernière réponse : ccm81
Messages postés
9062
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 août 2019
- 16 avril 2017 à 22:06
Bonjour à tous,

je souhaite remplacer les formules contenues dans les cellules excel par leur valeur. Mais seulement en laissant l'opération +.

Par exemple, si dans la cellule C3, j'ai inscris la formule =somme(A1:A12)+somme(B3:B14) et que somme(A1:A12)=123 et somme(B3:B14)=321, le resultat serait =123+321.

Si possible sous VBA car j'ai des milliers de formules que je ne souhaite pas transformer manuellement à l'aide de la touche F9.

Merci d'avance.
Afficher la suite 

5 réponses

Messages postés
24308
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 août 2019
4727
0
Merci
Bonjour
ça aurait peut être été plus simple avec directement cette formule:
=SOMME(A1:A12)&"+"&SOMME(B3:B14)

crdlmnt
Messages postés
2
Date d'inscription
vendredi 14 avril 2017
Statut
Membre
Dernière intervention
15 avril 2017
0
Merci
Merci beaucoup pour la réponse donnée. Mais en fait, je ne souhaite pas avoir pour résultat par exemple 123+321 dans la cellule ce que je veux c'est d'obtenir 444 (444=123+321). mais le contenu devrait avoir =123+321) et si possible avec code VBA.

Cordialement,
Messages postés
49664
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 août 2019
10478
0
Merci
=SOMME(A1:A12;B3:B14) & "=" & (SOMME(A1:A12) & "+" & SOMME(B3:B14)) devrait suffire.
Mais si tu veux le programmer en VBA, libre à toi !
Bonjour Raymond merci pour votre réponse mais je ne souhaite pas avoir dans la cellule un résultat du genre 444=123+321 mais plutôt 444 seul somme(A1:A12)+somme(B1:B6) devra être transformée en 123+321
Messages postés
9062
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 août 2019
1609
0
Merci
Bonjour à tous

Un petit essai très modeste
http://www.cjoint.com/c/GDpi1p4Ljts

Cdlmnt
Bonjour ccm81,
Super cool ça répond exactement à ma préoccupation.
Seulement comme j'ai une multitude de cellule la macro prend beaucoup de temps.

Mais le test sur une cellule marche super bien. pour boucler j'utilise for each... next

Y a til un autre moyen plus optimal?

Merci beaucoup.
Messages postés
9062
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 août 2019
1609
0
Merci
Tu peux mettre, si ce n'est pas déjà fait, en début de code, l'instruction
Application.ScreenUpDating = false
qui désactive le rafraichissement de l'écran à chaque recalcul

Cdlmnt