Connexion PDO [Résolu/Fermé]

Signaler
-
 siananox -
Bonjour,

En tapant le code suivant que mon prof m'a donné, qui fonctionne parfaitement pour les autres (toujours comme ça ^^)

<html>
<head>
<title>Devoir PHP</title>
<meta charset="UTF-8">
</head>
<body>

<?php
try {
$bd = new PDO('mysql:host=localhost;dbname=basem2_defi', 'root', '');
echo "connexion réussie";
}
catch (Exception $e) {
die("La connexion a échoué");
}
?>
</body>
</html>


La connexion ne se fait pas lorsque j'ouvre mon script dans le web local...

Des solutions?
Merci !

4 réponses

Messages postés
30
Date d'inscription
mardi 7 février 2017
Statut
Membre
Dernière intervention
19 juillet 2017
4
Bonjour,
Et si tu remplaces localhost par 127.0.0.1 ?

Sinon il faudrait remonter les erreurs PDO en ajoutant juste après l'instanciation de $bd :
$bd->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);


Puis dans le catch afficher l'erreur rencontrée :
catch (PDOException $e) { 
die("La connexion a échoué".$e->getMessage()); 
} 


http://www.commentcamarche.net/faq/46512-pdo-gerer-les-erreurs
Messages postés
542
Date d'inscription
mercredi 9 mars 2016
Statut
Membre
Dernière intervention
8 mars 2018
76
Ton serveur de base de données est lancé et accessible ?
Zucrezel, je vais essayer ça !

Rocailleux, oui oui il est accessible et ouvert dans mes onglets ;)
C'est bon ça fonctionne !!

Je pense que le soucis était dans le "getMessage", mon prof l'écrit ".e.getMessage" et dans le localhost que j'ai remplace par 127.0.0.1
Et puis GROSSE erreur de ma part, je nommais ma base de données basem2_defi alors qu'il fallait uniquement mettre son nom sans le "base" devant !

J'ai hélas pas fini mon devoir, donc je vous garde sous la main ;)
Avec un peu de chances on pourra clore ce sujet ce soir :D

Merci de votre aide !