Menu

Fonction NB.SI problème [Résolu/Fermé]

LéoTaba - 16 févr. 2017 à 07:44 - Dernière réponse :  LéoTaba
- 16 févr. 2017 à 10:37
Bonjour,
j'aurais souhaité savoir aussi s'il était possible d'insérer dans une formule NB.SI comme critère un renvoie sur un autre onglet car je n'y arrive pas.
Concrètement :
=NB.SI('Bilan STEP'!S4:S36;">'Références!F10'")
ne fonctionne pas, je m'explique : le critère ">'Références!F10'" renvoie à une case ou il y a écrit 375. Si dans la formule NB.SI je met comme critère >375, j'obtiens par exemple 3, alors que si je laisse le critère">'Références!F10'", peut importe la valeur de cette case, la formule donnera toujours 0.
Merci pour votre aide
Afficher la suite 

4 réponses

Vaucluse 21993 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 16 févr. 2017 à 07:53
0
Utile
Bonjour

essayez avec:

=NB.SI('Bilan STEP'!S4:S36;INDIRECT("Références!F10'"))

ou encore

=NB.SI('BilanSTEP'!S4:S36;INDIRECT(ADRESSE(10;6;;;"Référence")))

crdlmnt
0
Utile
Merci Vaucluse (toujours présent sisi)
Heu, le pb c'est que dans ma formule y a le comparateur > : oi dois je l'insérer dans ta formule ?
=NB.SI('Bilan STEP'!S4:S36;INDIRECT("Références!F10'"))
Vaucluse 21993 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 16 févr. 2017 à 10:07
Vi j'avais pas percuté sur la fonction du > et en fait mal pigé le problème. En fait indirect est inutile

=NB.SI('Bilan STEP'!S4:S36;">"&Références!F10))

il faut lier le signe entre guillemets et l'adresse par le signe &

valable quand le séparateur champ /valeur est le point virgule et quand le signe n'est pas une égalité (auquel cas il n'y a besoin de rien) et que la valeur cherchée est une adresse de cellule.

(SOMME.SI, NB.SI ETC..)

crdlmnt
0
Utile
ok merci !
RESOLU !