Menu

Problème de syntaxe fonction SI [Résolu/Fermé]

olis8319 55 Messages postés samedi 21 janvier 2017Date d'inscription 11 octobre 2017 Dernière intervention - 15 févr. 2017 à 12:50 - Dernière réponse : Mazzaropi 1834 Messages postés lundi 16 août 2010Date d'inscriptionContributeurStatut 30 mai 2018 Dernière intervention
- 16 févr. 2017 à 16:32
Bonjour,
j'ai un classeur avec entre autre 1 feuille (Info+Engagés) et 1 feuille (résultats)

Dans la feuille (Résultats) j'ai mis en cellule D11 la fonction =SI(ESTVIDE('Info+Engagés'!A12;'Info+Engagés'!H2);"";RANG(D10;$D$10:$D$49))

cette fonction doit me permettre soit ne rien afficher si les cellules (Info+Engagés A12 et H2) sont vide toutes les deux ou afficher en D11 un RANG par rapport a la valeur de D10

Problème il y a un argument de trop dans ma fonction quelqu'un aurait il une idée a me suggérer ?

Afficher la suite 

3 réponses

jordane45 21449 Messages postés mercredi 22 octobre 2003Date d'inscriptionModérateurStatut 24 juin 2018 Dernière intervention - 15 févr. 2017 à 12:59
0
Merci
Bonjour La fonction ESTVIDE n'attend qu'une seule valeur...
Tu peux faire un ET dans ton SI
un truc du genre

=SI(ET(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2));"";RANG(D10;$D$10:$D$49))

olis8319 55 Messages postés samedi 21 janvier 2017Date d'inscription 11 octobre 2017 Dernière intervention - Modifié par olis8319 le 16/02/2017 à 16:29
0
Merci
Merci jordan45 j'ai corrigé ma formule comme ceci:

=SI(OU(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2));"";('Cav1'!D38))

et cela fonctionne parfaitement
Mazzaropi 1834 Messages postés lundi 16 août 2010Date d'inscriptionContributeurStatut 30 mai 2018 Dernière intervention - 16 févr. 2017 à 16:32
0
Merci
olis8319, Bonjour.

Vérifiez que, maintenant, la formule fonctionne.

=SI( OU(ESTVIDE('Info+Engagés'!A12);ESTVIDE('Info+Engagés'!H2)); ""; 'Cav1'!D38)

J'espère avoir aidé.