Menu

Rechercher Valeur dans une colonne selon deux critères [Résolu/Fermé]

Sormick 83 Messages postés dimanche 10 novembre 2013Date d'inscription 7 mai 2018 Dernière intervention - 14 févr. 2017 à 20:00 - Dernière réponse : Mike-31 16133 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 24 mai 2018 Dernière intervention
- 14 févr. 2017 à 20:40
Bonjour,

J'ai un peu de mal à expliquer ce que je recherche.
Je vous envoie une photo de mon tableau. Je pense vous comprendrez mieux.

Cordialement,



Afficher la suite 

3 réponses

Mike-31 16133 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 24 mai 2018 Dernière intervention - Modifié par Mike-31 le 14/02/2017 à 20:24
0
Utile
Bonsoir,

il aurait été préférable d'avoir un bout de fichier qu'une capture écran, mais regarde comme cela

=SOMMEPROD(($A$2:$A$20=$L$1)*($B$2:$B$20=$M$1)*($C$2:$C$20))

si tu n'as qu'une formule tu peux travailler en relatif
=SOMMEPROD((A2:A20=L1)*(B2:B20=M1)*(C2:C20))

ou avec des plages nommées
=SOMMEPROD((Dat=L1)*(Nom=M1)*(Text))

tu peux également utiliser cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Sormick 83 Messages postés dimanche 10 novembre 2013Date d'inscription 7 mai 2018 Dernière intervention - 14 févr. 2017 à 20:25
Malheureusement j'ai une erreur #valeur! sur votre formule SOMMEPROD
Voici le tableau ci-joint:
http://www.cjoint.com/c/GBos1dAarKc
Mike-31 16133 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 24 mai 2018 Dernière intervention - 14 févr. 2017 à 20:40
0
Utile
Re,

utilise cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))