Menu

Erreur formule lecture cumulée sous excel [Résolu/Fermé]

MADO - 8 févr. 2017 à 11:24 - Dernière réponse : Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention
- 8 févr. 2017 à 14:32
Bonjour,


je ne parviens pas à mettre en place une formule, j'ai besoin de la chose suivante: =SI(ESTVIDE(A2);"Ouvert";"Terminé");SI((A4)="Non Valide";"Ouvert";"Terminé")

grosso modo si A2 est vide le dossier est ouvert et si A4 et non valide le dossier est ouvert, lecture a contrario si A2 est rempli ou A4 et valide le dossier est au statut terminé!

Merci pour votre aide
Afficher la suite 

7 réponses

Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 8 févr. 2017 à 11:30
0
Utile
6
Bonjour
sauf éventuelle erreur de compréhension

=SI(OU(ESTVIDE(A2);A4="non valide");"ouvert";"Terminé")

crdlmnt
Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention > MADO - 8 févr. 2017 à 11:45
alors simplement en inversant, non?

=SI(OU(A2<>"";A4="valide");"terminé";"ouvert")

ou encore:

=SI(OU(NON(ESTVIDE(A2));A4="valide");"terminé";"ouvert")


crdlmnt
Bonjour,

j'ai fini par trouver en repartant de votre proposition avec la formule ET plutôt que OU

Merci infiniment.
Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention > MADO - 8 févr. 2017 à 12:44
ce qui veut donc dire que le dossier reste ouvert si une des deux cellules ne contient pas la condition

(exemple A2 remplie et A4 non valide renvoie "ouvert")

ça ne répond pas à votre explication:

"Si la case A2 est remplie peu importe que le reste soit valide ou non le dossier doit apparaître en terminé"

mais si ça vous convient, c'est ok!et donc merci de pointer le sujet en résolu (en haut du fil sous le titre)

crdlmnt
Et BIEN bizarrement, non une des deux donne le résultat attendu
Vaucluse 21897 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 8 févr. 2017 à 14:32
C'est vous qui voyez, mais voir ici mon point de vue sur la question
https://mon-partage.fr/f/3yi71d41/
n'oubliez pas de pointer le sujet en résolu
Merci
crdlmnt