Mettre le nom d'un onglet dans une formule de calcul [Résolu/Fermé]

Signaler
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
-
mijean94
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
-
Bonjour,

J’ai des onglets dans mon classeur qui ont comme noms des années de 2005 à 2016 par exemple.

Dans un onglet, bilan, je fais des calculs, par exemple là sur l’onglet 2015 :

=SOMMEPROD(('2015'!$D$3:$D$215>DATEVAL($C$3))*('2015'!$H$3:$H$215=E6)*('2015'!$G$3:$G$215=F5)*('2015'!$I$3:$I$215))

Ma question:

Y a-t-il une solution pour mettre dans une cellule de mon onglet bilan le nom de l’onglet à prendre en compte dans le fonction ?

Merci pour vos aide.

Bien cordialement

4 réponses

Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
7
Bonjour,

J'ai trouvé la solution :

remplacer,
'2015'!$D$3:$D$215
par,
(INDIRECT("'" & E3 & "'!$D$3:$D$215"))

avec le nom dans la cellule E3

Bien cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62774 internautes nous ont dit merci ce mois-ci

Messages postés
7859
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
15 décembre 2019
1247
Bonjour,

Utilises INDIRECT()
mijean94
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
7
Bonjour,

Merci pour la réponse.
ça marche bien.

Bien cordialement