Recherche mots dans cellules Excel [Résolu/Fermé]

Messages postés
3
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
13 janvier 2017
-
Bonjour à tous,

je cherche de l'aide pour une formule :

dans le 1er onglet j'ai plusieurs colonnes dont une (la colonne N) dans laquelle se trouve du texte
dans un 2° onglet, j'ai une liste de 170 mots

je voudrais trouver une formule qui me permettrait de dire si oui ou non, au moins un des mots de la liste de l'onglet 2 est contenu dans les cellules de l'onglet 1 colonne N.

quelqu'un aurait il cette formule magique ?

un grand merci
Afficher la suite 

4 réponses

Messages postés
19
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
31 janvier 2019
1
0
Merci
Bonjour,

Dans ta colonne N de la feuille 1, ce sont des mots ou des phrases ?

Cordialement.
Messages postés
3
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
13 janvier 2017
0
Merci
bonjour,

ce sont des phrases.

cordialement
Messages postés
24733
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2019
4911
0
Merci
Bonjour

pas tout compris, mais on va essayer

à adapter

votre liste de mots de référence en X1:X170
votre champ à traiter en A1:A100
la formule:

=SOMMEPROD((NB.SI(A1:A100;"*"&$X$1:$X$170))*1)
vous donnera le nombre de textes co,ntenat au moins un mot de la liste en X.. et même plus si des textes contiennent plusieur mots de la liste

en complément
si vos textes commencent en A1, vous pouvez écrire en B1 (ou ailleurs):
=SOMMEPROD((NB.SI(A1;"*"&$X$1:$X$170&"*"))*1)
vous donnera combien de mots références différents sont contenus dans chaque cellule(en tirant la formule, bien sur)
  • Attention aux signes.
  • La liste de référence ici en X ne doit pas contenir de cellules vides


crdlmnt

Messages postés
3
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
13 janvier 2017
0
Merci
c'est ce qu'il me fallait, merci.
cordialement.
Vaucluse
Messages postés
24733
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2019
4911 -
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt