Remplir une case selon 3 conditions [Résolu/Fermé]

Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
- - Dernière réponse : MatyLou
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
- 7 janv. 2017 à 15:53
Bonjour,
J'ai fait le tour de plusieurs forum et je ne trouve pas ma formule magique! :)
Je vais tenter de m'expliquer clairement:
Je souhaite avoir une formule qui met automatiquement dans la cellule Q
- Soit un X si la cellule B est remplie et si la cellule C est vide.
- Soit rien si la cellule B est vide
- Soit rien si la cellule B est remplie et la C est également remplie

J'ai trouvé ma formule pour la cellule P, mais avec 3 conditions je n'y arrive pas.

Je vous remercie

Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
974
Date d'inscription
dimanche 18 mars 2007
Statut
Membre
Dernière intervention
14 mars 2017
218
1
Merci
Bonjour,

=SI(ESTVIDE(B4);"RIEN";SI(ESTVIDE(C4);"X";"RIEN"))

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60289 internautes nous ont dit merci ce mois-ci

Messages postés
24397
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2019
4766
0
Merci
Bonjour

=SI(OU(B2="";ET(B2<>"";C2<>""));"";"X")

quant à la condition pour P, quelle est elle?

crdlmnt
MatyLou
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
-
Pour la Cellule P, j'ai utilisé la formule =SI(ESTVIDE(B4);"X";""). Je voulais qu'un "X" apparaisse dans la cellule P si la Cellule C est vide, sinon rien.
MatyLou
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
-
J'ai un autre soucis, tjs avec le même dossier, pour ma cellule R

J'ai essayé: =SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4:B4;"m")))
Mais j'ai un message Err:511 qui apparaît.

j'aimerais pour cette cellule (R), calculer le nombre de jour (et non mois "m") entre la cellule A et B, mais uniquement s'il y a une date dans la cellule B.
Il me faut un format nombre car ensuite je dois calculer la moyenne.

cordialement
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
0
Merci
Super! Merci beaucoup pour votre réponse aussi rapide qui fonctionne exactement comme je le souhaitais!
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
0
Merci
J'ai un autre soucis, tjs avec le même dossier, pour ma cellule R

J'ai essayé: =SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4:B4;"m")))
Mais j'ai un message Err:511 qui apparaît.

j'aimerais pour cette cellule (R), calculer le nombre de jour (et non mois "m") entre la cellule A et B, mais uniquement s'il y a une date dans la cellule B.
Il faut que la case soit vide si A et/ou B sont vide et il me faut un format nombre car ensuite je dois calculer la moyenne total de ma colonne R.

Merci
jb.lugherini
Messages postés
974
Date d'inscription
dimanche 18 mars 2007
Statut
Membre
Dernière intervention
14 mars 2017
218 -
Voici la formule corrigée
=SI(ESTVIDE(A4);"";SI(ESTVIDE(B4);"";DATEDIF(A4;B4;"D")))

Cordialement,
MatyLou
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
> jb.lugherini
Messages postés
974
Date d'inscription
dimanche 18 mars 2007
Statut
Membre
Dernière intervention
14 mars 2017
-
:( Ca ne marche pas!
Ca me donne une date et ca ne me calcule pas le nombre de jours d'écart entre la cellule A et B.

Merci
MatyLou
Messages postés
7
Date d'inscription
samedi 7 janvier 2017
Statut
Membre
Dernière intervention
7 janvier 2017
> jb.lugherini
Messages postés
974
Date d'inscription
dimanche 18 mars 2007
Statut
Membre
Dernière intervention
14 mars 2017
-
Alors suis trop mauvaise aujourd'hui!!!... Ta formule marche très bien, je n'ai juste pas formaté ma cellule comme il fallait!
Merci bcp.