Menu

Inclusion ne fonctionne plus après migration de serveur [Fermé]

kirikou - 13 déc. 2016 à 22:12 - Dernière réponse : mamiemando 28452 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 21 juillet 2018 Dernière intervention
- 17 déc. 2016 à 14:26
Bonjour à tous,

J'ai fais iune migration de serveur avec mon code PHP et lorsque je le balance sur le nouveau serveur, cela ne me fait plus mon inclusion. Voici mon inclusion :

<?php include('header.php'); ?>


Je l'appel à partir de mon index.php.

La nouvelle machine est un CentOS 7 et sur lequel est redirigé vers le bon dossier grâce au virtual host.

Je suis quasiment sur que cela vient d'un Module PHP ) à activer car sur l'ancien serveur (Cpanel) cela fonctionne. En revanche ou trouver cette configuration...

Merci pour votre aide
Cordialement
Afficher la suite 

5 réponses

mamiemando 28452 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 21 juillet 2018 Dernière intervention - 14 déc. 2016 à 10:05
0
Merci
Bonjour,

Je viens de faire le test et cela ne fonctionne pas...

Merci
mamiemando 28452 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 21 juillet 2018 Dernière intervention - 15 déc. 2016 à 10:16
0
Merci
As-tu eu des messages d'erreur, si oui lesquels ?
0
Merci
Bonjour,

Je n'est aucun de message d'erreur rien. En revanche j'ai fais une avancée. Le problème vient bien de PHP. Malgré qui soit installé. Quand je tape du PHP il est affiché comme une ligne de commentaire.

Du coup je sens que je vais me faire une ré-installation d'OS cela sera plus simple.

Merci pour votre aide !
Cordialement
mamiemando 28452 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 21 juillet 2018 Dernière intervention - 17 déc. 2016 à 14:26
0
Merci
Tu veux dire que le PHP n'est pas interprété par apache, et il est affiché comme si c'était du texte ordinaire. Si c'est le cas, ça veut dire que le module PHP n'est pas activé au niveau d'apache.

Sous debian on taperait quelque chose du genre
a2enmod php
puis on relancerait apache avec
service apache2 restart
. Essaye de trouver l'équivalent pour ta distribution.

Bonne chance