Menu

2 fonctions Vrai dans une cellule [Résolu/Fermé]

godinsonia 25 Messages postés dimanche 22 août 2010Date d'inscription 9 novembre 2017 Dernière intervention - 29 nov. 2016 à 17:32 - Dernière réponse : Vaucluse 21884 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention
- 29 nov. 2016 à 19:43
Bonjour,
j'aimerais mettre dans ma formule si D2= 1 vrai 39 et si D2 =2 vrai 61.50 si faux rien ("")
je ne sais pas si cela peut se faire ou non.

voici ma formule erronée: =SI(OU(D2=1;2);39;61,5;"";"")

merci de m'aider

Sonia
Afficher la suite 

5 réponses

Vaucluse 21884 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 29 nov. 2016 à 17:38
0
Utile
4
Bonjour
=SI(D2=1;39;SI(D2=2;61,5;""))
crdlmnt
godinsonia 25 Messages postés dimanche 22 août 2010Date d'inscription 9 novembre 2017 Dernière intervention - 29 nov. 2016 à 18:23
MERCI beaucoup ! et si on a plus de 2 conditions, genre 3....la formule serait quoi svp
Vaucluse 21884 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 29 nov. 2016 à 18:26
=SI(Cell=condition1;résultat1,SI(Cell=condition 2;résultat2;SI(Cell=condition3;résultat3;SI(....;SI(....;"")))))
avec à la fin autant de parenhèses que de SI.
Mais si vous en avez beaucoup mieux vaut passer par un tableau de références et une formule de recherche
cham
crdlmnt
godinsonia 25 Messages postés dimanche 22 août 2010Date d'inscription 9 novembre 2017 Dernière intervention > Vaucluse 21884 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention - 29 nov. 2016 à 19:11
merci beaucoup c'est super gentil de m'aider

malheureusement je ne me souviens plus comment faire avec une formule de recherche mais je vais essayer de trouver.

bonne journée
Sonia
Vaucluse 21884 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 avril 2018 Dernière intervention > godinsonia 25 Messages postés dimanche 22 août 2010Date d'inscription 9 novembre 2017 Dernière intervention - 29 nov. 2016 à 19:43
tableau de recherche

exemple à adapter

de X1 à x10 la liste des valeurs (ou textes) de la cellule condition Cell
de Y1 à Y10 la liste des valeurs à obtenir en conséquence

dans la cellule résultat

=SIERREUR(RECHERCHEV(Cell;$X$1:$Y$10;2;0);"")

ou pour excel avant 2007

=SI(NB.SI($X$1:$X$10;Cell);RECHERCHEV(Cell;$X$1:$Y$10;2;0);"")

cell étant dans votre cas D2 sauf erreur


crdlmnt