Menu

HElppp plzzz Excel Fonction [Résolu/Fermé]

Ams2020 4 Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 09:59 - Dernière réponse : Ams2020 4 Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention
- 29 nov. 2016 à 15:35
Bonjour et merci d'avance

vous trouvez ma question dans la l'image ci-joint






Merci bqqqqqqqqq
Afficher la suite 

6 réponses

Vaucluse 21883 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - Modifié par Vaucluse le 29/11/2016 à 10:18
0
Utile
3
Bonjour
si votre tableau commence en A:

=NB.SI.ENS(F:F;"<0";G:G;"<100%")
_ pour excel à partir de 2007

Excel, avant 2007:
=SOMMEPROD((F1:F1000<0)*(G1:G1000<100%))
(N° de lignes obligatoires avec ce code)

Pour éviter d'afficher des jours négatifs dans la colonne temps restant si la tâche est finie, vous devriez placer cette formule:
=SI(G2=100%;"";AUJOURDHUI()-date début)

la formule pour compter les taches en retard serait plus simple:

=NB.SI(F:F;"<0")


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Ams2020 4 Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 10:54
MErci bqqq mais ca marche si il a que le metier achat
par contre moi jai d'autre metier commerce / conception et autre

moi je veux que le nombre des taches en retard par metier

Merci bqqqqqqqqqq Vaucluse
Vaucluse 21883 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - 29 nov. 2016 à 11:39
Votre tableau ne précisait pas qu'il y avait plusieurs métiers, ikl suffit de rajouter une co,ndition:

=NB.SI.ENS(C:C;E11;F:F;"<0";G:G;"<100%")

=SOMMEPROD(($C$1:$C$1000=E11)*($F$1:$F$1000<0)*($G$1:$G$1000<100%))

crdlmnt
Ams2020 4 Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention > Vaucluse 21883 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - 29 nov. 2016 à 15:35
MErci bqqq
Utilisateur anonyme - 29 nov. 2016 à 12:23
0
Utile
1
Bonjour Ams2020,

Vaucluse (que je salue) t'a donné une très bonne solution et de
très bons conseils ; c'est en suivant ce qu'il a proposé que je te
joins ce fichier Excel 2007.

En F3   : =SI(G3<1;E3-F$7;"")
En F11 : =NB.SI.ENS(C3:C5;E11;F3:F5;"<0")

Donc j'ai bien suivi son conseil d'afficher le temps restant seulement
si Réalisé < 100 % ; mais par contre, je crois qu'il est préférable de
mettre les numéros de ligne même pour NB.SI.ENS() car la formule
elle-même est en colonne F puisqu'en F11.

J'ai supposé que dans ton vrai fichier il y a bien évidemment plus de
lignes, et au cas où tu as quand même mis ta formule en colonne F,
ma formule avec numéros de lignes « s'arrêtera » à la dernière ligne
de ton tableau (si tu as adapté correctement).

Si ton problème est réglé, n'oublie pas de remercier Vaucluse, puis
d'aller en haut de page pour cliquer sur « Marquer comme résolu ».

Cordialement.  :)
 
Ams2020 4 Messages postés mardi 29 novembre 2016Date d'inscription 29 novembre 2016 Dernière intervention - 29 nov. 2016 à 15:35
MErci bqqqq