Menu

Fonction multiples liées à des feuilles sur un autre fichier [Résolu/Fermé]

semoCRG 2 Messages postés mardi 22 novembre 2016Date d'inscription 24 novembre 2016 Dernière intervention - 22 nov. 2016 à 11:01 - Dernière réponse : semoCRG 2 Messages postés mardi 22 novembre 2016Date d'inscription 24 novembre 2016 Dernière intervention
- 24 nov. 2016 à 07:38
Bonjour,

Je ne suis pas une experte en Excel et j'ai besoin de votre aide.

J'ai un fichier excel qui me sert à la facturation (mes devis et factures sont créées sur ce document).

Dans une cellule, j'ai trois options à choix : devis, facture et facture interne.
Dans la cellule d'à côté, j'ai besoin que le n° de devis, facture, etc. s'affiche automatiquement en allant chercher la valeur ad-hoc dans un autre fichier (fichier avec des tableaux récapitulatifs).

Dans cet autre fichier, j'ai trois feuilles contenant chacune un relevé numéroté des devis, factures et factures internes.

Le nouveau n° de devis, facture, etc. va donc être égal au dernier chiffre saisi dans le fichier récapitulatif +1.

J'ai trois formules qui utilisées toutes seules fonctionnent parfaitement :

=SI(D14="Devis Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau devis'!$B$5:$B$80)+1)

=SI(D14="facture Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau facture'!$B$5:$B$80)+1)

=SI(D14="Factures Interne Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau factures internes'!$B$5:$B$80)+1)

Mon problème est que je n'arrive pas à grouper ces trois formules en une seule afin que le système applique le chiffre correspondant au nouveau devis, facture, etc.

Merci d'avance pour votre aide
Patricia
Afficher la suite 

3 réponses

Meilleure réponse
Raymond PENTIER 46082 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 juin 2018 Dernière intervention - 23 nov. 2016 à 03:19
1
Merci
Bonjour, jeune Suissesse !

=SI(D14="Devis Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau devis'!$B$5:$B$80)+1 ;
SI(D14="facture Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau facture'!$B$5:$B$80)+1 ;
SI(D14="Factures Interne Service traiteur";MAX('[chiffre d''affaire_devis et factures ext et int.xlsx]Tableau factures internes'!$B$5:$B$80)+1) ))

Merci Raymond PENTIER 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24578 internautes ce mois-ci

Raymond PENTIER 46082 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 juin 2018 Dernière intervention - 23 nov. 2016 à 03:29
... et si tu définis le nom "devis" pour la plage [chiffre d''affaire_devis et factures ext et int.xlsx]Tableau devis ; le nom "fact" pour la plage [chiffre d''affaire_devis et factures ext et int.xlsx]Tableau facture ; le nom "IST" pour la plage [chiffre d''affaire_devis et factures ext et int.xlsx]Tableau factures internes, ta formule s'écrit plus simplement
=SI(D14="Devis Service traiteur";MAX(devis'!$B$5:$B$80)+1;
SI(D14="facture Service traiteur";MAX(fact!$B$5:$B$80)+1;
SI(D14="Factures Interne Service traiteur";MAX(IST!$B$5:$B$80)+1)))
semoCRG 2 Messages postés mardi 22 novembre 2016Date d'inscription 24 novembre 2016 Dernière intervention > Raymond PENTIER 46082 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 18 juin 2018 Dernière intervention - 24 nov. 2016 à 07:38
ça marche, Merci beaucoup et belle retraite aux Antilles :-)