Menu

Formule si pour un test sur une colonne [Résolu/Fermé]

Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
- - Dernière réponse : mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
- 12 nov. 2016 à 21:07
Bonjour,

Le code si dessous test si la cellule est vide et affiche bon ou erreur s’il y a une donnée.

=SI(ESTVIDE(B2);"Bon";"Erreur")


Mon interrogation :

Comment faire pour que le test soit réalisé sur la plage B2 :B100 ?

Merci de l’aide

Bien cordialement
Afficher la suite 

2 réponses

Messages postés
28242
Date d'inscription
mercredi 28 novembre 2007
Statut
Modérateur, Contributeur sécurité
Dernière intervention
28 mai 2019
3240
0
Merci
Bonjour,

Utilise plutôt cette formule :
=SI(NBVAL(B2:B100)=0;"Bon";"Erreur")
mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
7 -
Bonjour,

Merci pour la réponse.

J’ai peut-être mal formulé ma demande. Ce que je cherche à faire est :

Si toutes les cellules de la plage B2 :B100 sont vident, et uniquement dans ce cas, afficher bon sinon erreur.

Rectification : ta proposition marche nickel. j'avais fait une erreur dans la recopie.

Bien cordialement
crapoulou
Messages postés
28242
Date d'inscription
mercredi 28 novembre 2007
Statut
Modérateur, Contributeur sécurité
Dernière intervention
28 mai 2019
3240 > mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
-
Parfait, bonne soirée.
Bonjour aussi au passage albkan.
0
Merci
Bonjour mijean94,

Cette formule matricielle, à valider par < Ctrl >< Shift >< Entrée >,
devrait faire l'affaire : =SI(ESTVIDE(B2:B100);"Bon";"Erreur")

< Shift > est la touche < Maj > située juste au-dessus de < Ctrl >.

Cordialement.  😊


PS : Bonjour à crapoulou en passant.  😉
mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
7 -
Bonjour,

Merci pour cette réponse mais j'avais testé cette solution qui ne fonctionne pas.
J'ai pris la solution du post1 qui est nickel.

Merci à tous et bonne soirée.

Bien cordialement
Utilisateur anonyme > mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
-
 
Bonjour mijean94,

Je viens de tester ma solution, qui a marché tout de suite, du premier coup.
Donc cette solution est tout à fait correcte, mais tu as dû oublier de valider
la formule avec < Ctrl >< Shift >< Entrée > !

Cela dit, la solution du message #1 de crapoulou est très bien aussi !

Mais parfois, selon les données, le test sur 0 (zéro) ne marche pas,
et il vaut mieux alors faire un test sur la valeur vide ; c'est pourquoi
j'avais ajouté ma solution, au cas où...

Bonjour à crapoulou en passant.  😉

Cordialement.  😊
mijean94
Messages postés
330
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
15 janvier 2018
7 > Utilisateur anonyme -
Bonjour albkan,

Effectivement j'ai testé une nouvelle fois ta solution est elle marche bien dans mon programme d'essai, mais lorsque je l'ai mise en place dans mon programme d'ensemble il y avait toujours une erreur. Peut-être que le défaut ne vient pas de ta proposition mais d'autre chose dans mon code même en validant la formule.

Merci encore

Bien cordialement