Afficher bon si trois conditions sont remplies dans une colonne [Résolu/Fermé]

Signaler
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
-
mijean94
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
-
Bonjour,

Je souhaiterais trouver la formule Excel pour :

Dans une colonne A1/A50 :

Si la dernière cellule qui est renseignée contient bien la valeur 2 et si la première cellule renseignée contient bien la valeur 1.

Il peut y avoir, dans les autres cellules, les mêmes valeurs.
La première cellule renseignée n’est pas obligatoirement la cellule A1 et la dernière n’est pas obligatoirement A50.

Pouvoir ajouter ces deux conditions à la formule si dessous :

=SI(ENT((SOMME(A1:A50))/3)*10=((SOMME(A1:A50))/3)*10;"Bon";Décimal)


Merci de votre aide.

Bien cordialement

4 réponses

Messages postés
2527
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 décembre 2019
292
Bonjour,

Un essai :
http://www.cjoint.com/c/FKhsB0z7Cvr
Crdmt
mijean94
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
7
Bonjour,

Je souhaiterai rajouter dans le code si dessous une contrainte supplémentaire avec un :

OU si D3:D302 = "" donne "erreur" car dans ma ligne s'il n'y a pas de donnée j'ai #N/A comme la somme de la colonne n'est pas correcte.

=SI(ET(SOMME(DECALER(D3;0;0;EQUIV(1;D3:D302;0);1))=1;RECHERCHEV(9999;D3:D302;1;1)=2;ENT((SOMME(D3:D302))/3)*10=((SOMME(D3:D302))/3)*10);"Bon";"Erreur")

Merci pour l’aide, car je n’ai pas trouvé comment ajouter cette condition.

Bien cordialement
Messages postés
341
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
7 novembre 2019
7
Bonjour,

Merci bien, ça fonctionne nickel.

Bonne soirée

bien cordialement