Menu

Formule Si à plusieurs conditions [Résolu/Fermé]

aquaro 4 Messages postés mardi 18 octobre 2016Date d'inscription 18 octobre 2016 Dernière intervention - 18 oct. 2016 à 02:00 - Dernière réponse : aquaro 4 Messages postés mardi 18 octobre 2016Date d'inscription 18 octobre 2016 Dernière intervention
- 18 oct. 2016 à 12:37
Bonjour,

Cela fait quelques jours que je suis bloquée sur une formule SI qui contient plusieurs conditions :


Le TAUX ACCORDÉ doit être ajouté automatiquement par rapport au TOTAL BRUT en se référant au tableau Montant/Taux de remise.

Merci d'avance :)

--
Afficher la suite 

9 réponses

Raymond PENTIER 45584 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - Modifié par Raymond PENTIER le 18/10/2016 à 02:44
0
Utile
1
Bonjour aquaro, et sois la bienvenue parmi les membres de CCM

Ton image est très jolie, mais nous préférerions le vrai fichier Excel :
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (8192 Ko maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Et pense à préciser si la remise se calcule tranche par tranche ou sur le montant global !

Cordialement.

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
aquaro 4 Messages postés mardi 18 octobre 2016Date d'inscription 18 octobre 2016 Dernière intervention - 18 oct. 2016 à 10:48
Merci pour l'astuce ! Je n'ai pas l'habitude des forums...

Sinon c'est tranche par tranche

http://www.cjoint.com/c/FJsiUS7f5w8
Merci beaucoup !
Raymond PENTIER 45584 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - Modifié par Raymond PENTIER le 18/10/2016 à 02:51
0
Utile
Dans le cas où le calcul se fait sur le montant global, et non par tranche, la formule en G:G sera
=SI(F:F<10000;0%;SI(F:F<25000;1%;SI(F:F<50000;2%;
SI(F:F<75000;3%;SI(F:F<100000;4%;SI(F:F<125000;5%;
SI(F:F<150000;6%;SI(F:F<250000;7%;10%))))))))*F:F

qui peut aussi s'écrire
=SI(F:F<10000;0;SI(F:F<25000;1;SI(F:F<50000;2;
SI(F:F<75000;3;SI(F:F<100000;4;SI(F:F<125000;5;
SI(F:F<150000;6;SI(F:F<250000;7;10))))))))*F:F%


C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Utilisateur anonyme - 18 oct. 2016 à 02:48
0
Utile
1
Bonjour aquaro,

Je te propose cette formule en G2 (à tirer vers le bas jusqu'en G11) :

=SI(F2<A$16;B$15;SI(F2<A$17;B$16;SI(F2<A$18;B$17;SI(F2<A$19;B$18;SI(F2<A$20;B$19;SI(F2<A$21;B$20;SI(F2<A$22;B$21;SI(F2<A$23;B$22;B$23))))))))

Je te laisse essayer cette formule, et me dire si ça te convient.

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊


@Raymond : avec un zoom sur l'image, qui est vraiment bien nette,
je m'en suis arrangé ; en plus, ça fait plaisir de voir les en-têtes de
lignes et colonnes : on voit tout de suite où sont les données !
 
aquaro 4 Messages postés mardi 18 octobre 2016Date d'inscription 18 octobre 2016 Dernière intervention - 18 oct. 2016 à 12:34
Super merci la formule fonctionne ! J'avais fait comme ça au départ, mais mes cellules donnaient toutes le même résultat, j'ai dû rater quelque chose.

Cordialement. :)
Raymond PENTIER 45584 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 18 oct. 2016 à 03:06
0
Utile
... mais si le tableau des taux de remise est susceptible de mises à jour fréquentes, on préférera la formule avec les références de cellules
=SI(F:F<$A$16;$B$15;SI(F:F<$A$17;$B$16;SI(F:F<$A$18;$B$17;
SI(F:F<$A$19;$B$18;SI(F:F<$A$20;$B$19;SI(F:F<$A$21;$B$20;
SI(F:F<$A$22;$B$21;SI(F:F<$A$23;$B$22;$B$23))))))))*F:F

JvDo 1814 Messages postés mercredi 27 juillet 2005Date d'inscription 20 avril 2018 Dernière intervention - 18 oct. 2016 à 03:15
0
Utile
2
Bonsoir à tous,

Essaye la formule en G2:
=RECHERCHEV(F2;$A$15:$B$23;2;VRAI)


Cordialement

PS : n'oublie pas de mettre un 0 en A15
Raymond PENTIER 45584 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 18 oct. 2016 à 03:31
Absolument !
Je suis tellement habitué à l'argument FAUX que j'en oublie l'usage de l'argument VRAI ...

aquaro, oublie mes formules à rallonge et adopte la formule de JvDo ;
c'est elle qui convient, bien entendu !
Et si tu donnes le nom "taux" à la plage A15:B23 la formule pourra même s'écrire
=RECHERCHEV(F:F;taux;2;1)
aquaro 4 Messages postés mardi 18 octobre 2016Date d'inscription 18 octobre 2016 Dernière intervention - 18 oct. 2016 à 12:37
C'est vrai que la recherche V est la plus cohérente, je l'utilise souvent dans mes tableaux, mais là mes consignes étaient la formule SI à plusieurs conditions ... En tout cas merci ! :)