Avoir le wifi sur lubuntu (RSKILL) [Fermé]

Messages postés
882
Date d'inscription
vendredi 3 janvier 2014
Statut
Membre
Dernière intervention
28 juillet 2018
-
bonjour,

je viens d'installer lubuntu et je ne parvient pas à avoir le wifi :

root@anthony-X75VD:~# sudo ifconfig wlan0 up
SIOCSIFFLAGS: Opération impossible du fait de RF-kill
root@anthony-X75VD:~#



anthony@anthony-X75VD:~$ sudo -s
[sudo] password for anthony:
root@anthony-X75VD:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
root@anthony-X75VD:~# lshw -class network
  • -network DÉSACTIVÉ description: Interface réseau sans fil produit: RT5390 Wireless 802.11n 1T/1R PCIe fabriquant: Ralink corp. identifiant matériel: 0 information bus: pci@0000:03:00.0 nom logique: wlan0 version: 00 numéro de série: 84:4b:f5:01:07:48 bits: 32 bits horloge: 33MHz fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rt2800pci driverversion=4.4.0-42-generic firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn ressources: irq:17 mémoire:f7900000-f790ffff *-network description: Ethernet interface produit: AR8161 Gigabit Ethernet fabriquant: Qualcomm Atheros identifiant matériel: 0 information bus: pci@0000:04:00.0 nom logique: eth0 version: 10 numéro de série: 30:85:a9:79:ea:23 capacité: 1Gbit/s bits: 64 bits horloge: 33MHz fonctionnalités: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair ressources: irq:34 mémoire:f7800000-f783ffff portE/S:d000(taille=128)root@anthony-X75VD:~#


et même si je fais :
root@anthony-X75VD:~# rfkill unblock all
root@anthony-X75VD:~# rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
root@anthony-X75VD:~#

et que je redémarre, hard blocked reste sur no.


et c'est là que je me demande si windaube était pas mieux...
PS : mon bouton pour activer le wifi (fn + f2) ne fonctionne pas : le wifi s'active, puis s'arrête quelques secondes plus tard
merci à ceux qui m'aideront
Afficher la suite 

4 réponses

Messages postés
1503
Date d'inscription
mercredi 8 août 2012
Statut
Membre
Dernière intervention
18 mai 2019
133
0
Merci
Tu fais tourner Lubuntu en live, c'est à dire que tu fais comme si tu installais, mais tu choisis l'option : essayer ubuntu sans rien changer au disque dur. Quand ton PC tourne en live, tu vois si tu peux le mettre sur internet... si ça marche, c'est qu'il y a un paquet qui ne s'est pas installé. Je te conseille alors, de rester sur internet, de cocher l'option : "installer", donc de réinstaller, et tout devrait marcher.
artemis0
Messages postés
882
Date d'inscription
vendredi 3 janvier 2014
Statut
Membre
Dernière intervention
28 juillet 2018
94 -
merci beaucoup de cette réponse !

j'ai pas trop compris ce que tu as voulu dire par :

tu vois si tu peux le mettre sur internet... si ça marche, c'est qu'il y a un paquet qui ne s'est pas installé. Je te conseille alors, de rester sur internet, de cocher l'option : "installer", donc de réinstaller, et tout devrait marcher.
Messages postés
1503
Date d'inscription
mercredi 8 août 2012
Statut
Membre
Dernière intervention
18 mai 2019
133
0
Merci
Quand ton PC tourne en live, tu peux constater que tout marche, mais c'est seulement plus lent, car tu fonctionnes à partir du disque (ou de la clé) et non à partir du disque dur. Donc, tu cliques sur le symbole du wifi, (en général deux écrans emboités) et si ton PC t'indique quels box il reçoit, c'est bon !... tu mets le code, tu es sur internet, et tu peux réinstaller.
Messages postés
882
Date d'inscription
vendredi 3 janvier 2014
Statut
Membre
Dernière intervention
28 juillet 2018
94
0
Merci
finalement j'ai remis windows.

j'avais essayé plein de distib linux différentes, et il y avait toujours le problème du wifi. parfois l'iso s'installait même pas (comme avec raspbian) et ça disait de charger les pilotes de la carte wifi manuellement (que je n'ai pas trouvés d'ailleurs). après j'ai réussi a faire fonctionner le pc avec lubuntu 12, mais il y avait des gros bugs (barre de menu démarrer qui a disparu et impossible de la faire réapparaitre), ensuite j'ai essayé lubuntu 16, ça fonctionnait bien au début, mais vmware fonctionne pas dessus (service qui arrive pas à démarrer, et les patch que j'ai trouvé sur le net ne fonctionnaient pas).

je mettrai linux quand ce sera stable et que ça fonctionnera.

merci quand même pour ton aide bmw
0
Merci
Bonjour,

"je mettrai linux quand ce sera stable et que ça fonctionnera."

Linux est stable et fonctionne. C'est pas la faute de la communauté linux si le fabricant de ta carte wifi n'est pas fichu de mettre un driver linux propre à la disposition des utilisateurs. Et si ralink rendait publiques les caractéristiques de la carte, il y a belle lurette qu'il y aurait un driver libre fonctionnel disponible !

Alors s'il te plaît, ne t'en prend pas à la communauté linux, c'est ton matos qui est en cause parce que le fabricant se fout complètement de linux et ne développe que pour Windows !