Menu

Extraire une liste de date [Résolu/Fermé]

JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 13 oct. 2016 à 10:40 - Dernière réponse : JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention
- 14 oct. 2016 à 11:56
Bonjour à tous,

Je rencontre actuellement un soucis sous excel 2013
J'ai un tableau avec en colonne A des dates et en colonne B des valeurs de consommation
On me demande de sortir la liste des dates correspondant à une consommation supérieur à un nombre. (47000)
La fonction NB.SI me dit bien que sur ma plage de temps 3 jours sont concernés par une consommation supérieur à 47000 hors je n'arrive pas à faire ressortir ces dates j'avoue que je pourrai choisir la solution de facilité, mettre un filtre sur ma colonne de consommation et trouver manuellement les dates concernées mais j'aimerais savoir si il existe une fonction adapté à cette demande.

Merci d'avance pour vos réponse
Une très bonne journée à tous
Afficher la suite 

10 réponses

Fahora 797 Messages postés jeudi 24 septembre 2015Date d'inscription 29 juin 2017 Dernière intervention - 13 oct. 2016 à 11:11
0
Utile
1
Bonjour ,

plusieurs solutions pour obtenir les dates.
Dans la colonne C :
=Si(B2 > 47000 ; A2;"") cela t'inscrira les dates dans la colonne C pour lesquelles la consommation est supérieure à 47000

Sinon pourquoi ne pas faire une mise en forme conditionnelle ?
Afin de mettre en évidence les dates concernées

Cordialement,
JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 13 oct. 2016 à 13:51
Merci Fahora pour la rapidité de ta réponse, pour ne rien te cacher je commence seulement à utiliser Excel "correctement" du fait de ma nouvelle activité, dans mon ancien Job je n'avais jamais autant de données à traiter, tableau simple très peut de lignes, du coup je me posé pas les bonnes questions. Maintenant c'est différent, j'ai le nez dans Excel à longueur de journée je me doit de me perfectionner pour être efficace, et tu m'aide beaucoup dans ce sens.....encore merci
eriiic 21538 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 13 oct. 2016 à 11:43
0
Utile
1
Bonjour,

Tu as aussi le filtre avancé qui te permet d'extraire dans une autre zone.
eric
JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 13 oct. 2016 à 13:56
Merci pour ta réponse eriiic je vais également me pencher sur la solution que tu me propose je suis sure que cela me servira, je me rend compte en lisant chacune de vos réponse qu'il y a quant même pas mal de solution à mon problème, ce qui me fait pensé que j'ai énormément de lacune sur le sujet, je pense que demander une formation excel à mon employeur ne serai pas du lux....encore merci.
yclik 1283 Messages postés vendredi 25 juillet 2014Date d'inscription 17 avril 2018 Dernière intervention - Modifié par yclik le 13/10/2016 à 13:07
0
Utile
5
Bonjour
une proposition de solution
Avec la formule n D2
=SI(ESTERREUR(PETITE.VALEUR($C$2:$C$13;LIGNE()-1));"";INDIRECT("A"&PETITE.VALEUR($C$2:$C$13;LIGNE()-1)))

JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 13 oct. 2016 à 14:12
Bonjour yclik,
Merci pour ta réponse et illustrée en plus....que demande le peuple !!! ta solution me va bien, tu va faire un heureux (mon directeur). Bonne journée à toi
JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 14 oct. 2016 à 11:16
C'est plutôt complexe, j'essaye de comprendre les formules en D2 et E2. Dans mon cas sur les trois dates concernées je n'arrive à en extraire qu'une seule, lorsque je recopie la formule vers le bas mes cellules reste vides.
yclik 1283 Messages postés vendredi 25 juillet 2014Date d'inscription 17 avril 2018 Dernière intervention > JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 14 oct. 2016 à 11:36
bonjour
pour recopier bien mettre le référencement de la plage de recherche $C$2:$C$13

=SI(ESTERREUR(PETITE.VALEUR($C$2:$C$13;LIGNE()-1));"";INDIRECT("A"&PETITE.VALEUR($C$2:$C$13;LIGNE()-1)))


PETITE.VALEUR($C$2:$C$13;LIGNE()-1
renvoie la 1ère plus petite valeur de la plage $C$2:$C$13
ligne()-1 permet d'avoir 1 pour la ligne 2 du tableau
ligne()-1 permet d'avoir 2 pour la ligne 3 du tableau
...

SI(ESTRREUR permet de ne rien mettre "" si pas trouvé de valeur sinon renvoie la cellule col A ligne x récupérée avec PETITE.VALEUR
eriiic 21538 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 14 oct. 2016 à 11:34
Un filtre avancé te fait ça sans aucune formule, juste une zone de critères à préparer.
eric
JuliosLoco 9 Messages postés jeudi 13 octobre 2016Date d'inscription 14 octobre 2016 Dernière intervention - 14 oct. 2016 à 11:56
Merci à vous, problème résolu peut être un problème de format de cellule...Merci pour les explications, un bon Week end à vous.