Menu

Fonction S pour 3 plages horaires différentes [Résolu/Fermé]

ZoeB - 11 oct. 2016 à 12:39 - Dernière réponse :  ZoeB
- 11 oct. 2016 à 13:23
Bonjour,

Je n'arrive pas à etablir ma fonction :
J'ai trois plages horaires qui sont :
00:00 à 06:20 = C
06:20 à 12:40 = A
12:40 à 23:59 = B
J'ai placé mes différentes plages horaires dans des cellules pour les mettre au format (format "hh:mm") correspondant au format des horaires que je veux classer : pour la fonction SI :
06:20 = $AP$3
12:40 = $AP$4
00:00 = $AP$2
Voilà le désastre :
=SI(ET(K4>$AP$3;K4<$AP$4);"A";SI(E(K4>$AP$2;K4<$AP$3);"C";"B"))

Mon problème est qu'il détecte que 06:28>06:20 mais pas que 06:28<12:40


Afficher la suite 

2 réponses

Gyrus 3341 Messages postés samedi 20 juillet 2013Date d'inscription 9 décembre 2016 Dernière intervention - 11 oct. 2016 à 12:56
0
Utile
Bonjour,

Essaie avec :
=SI(K4<=$AP$4;SI(K4<$AP$3;"C";"A");"B")

A+
Merci , l'idée est bien plus simple que la mienne, cependant toujours ce meme problème par exemple :

K56 (00:28) <=$AP$4 (12:40)
--> Il me dit : Réponse au test : FAUX
Et donc toute ma colonne est égale à B

Merci d'avance,

Zoé