Liste déroulante avec saisie semi-automatique [Résolu/Fermé]

Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
-
Bonjour à tous !

J'ai regardé le tuto http://www.commentcamarche.net/faq/8288-liste-deroulante-avec-saisie-semi-automatique-pour-excel#simili_main

Problème : La formule à écrire dans "Source" dans l'onglet "Options" ne fonctionne malheureusement pas. "La source est reconnue comme erronée, voulez-vous continuer?" Y aurait-il une erreur dans la formule?

Merci d'avance.

Cordialement.
Afficher la suite 

3 réponses

Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
50
0
Merci
Bonjour ,

tout est correct. Je l'ai fais la semaine dernière, et il n'y avait pas de problème.

Éventuellement, déposes nous ton fichier qu'on puisse voir ce qui ne colle pas.

Allez sur ce site : http://cjoint.com
Clic
sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...


Cordialement,
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
450
0
Merci
Bonjour,

Vérifie en particulier que tu as bien respecté cette partie :

Dans l'onglet "Options" dans la zone "Source :" nous allons saisir la formule suivante : =SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMMEPROD((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms) en remplaçant A1 par l'identification de la première cellule sélectionnée (c'est-à-dire la 1ère cellule ayant une validation par liste).

A+
Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
28
0
Merci
Bonjour,

Tout fonctionne merci pour les infos. L'erreur venait de moi.

Cordialement.