Problème UPLOAD sur Serveur [Résolu/Fermé]

Signaler
Messages postés
390
Date d'inscription
dimanche 1 mars 2015
Statut
Membre
Dernière intervention
11 juillet 2019
-
Grandasse_
Messages postés
855
Date d'inscription
jeudi 28 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2018
-
Bonjour,
Je n'obtiens rien quand je fais un formulaire et j'envoie une photo, le code du formulaire :

<form method="post" action="test.php" enctype="multipart/form-data">
<input type="file" name="image"/><br/>
<input type="submit" value="Publier" class="myButton"/>
</form>

Et le fichier qui recois :
$time = time();
$nom = "envoie/mini" . $time . ".png";
$resultat = move_uploaded_file($_FILES['icone']['tmp_name'],$nom);

Et je n'ai rien, je ne sais pas comment faire, j'ai fait ca grâce à un tuto d'OpenClassrooms.
Merci !

2 réponses

Messages postés
699
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
4 décembre 2016
78
Bonjour,

Grandasse,
la récupération d'un input file est bien $_FILES et non $_POST,
l'attribut method n'est pas non plus le problème.

Coté Html le champ file à comme name image,
et coté PHP on a icone
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86760 internautes nous ont dit merci ce mois-ci

spylller
Messages postés
390
Date d'inscription
dimanche 1 mars 2015
Statut
Membre
Dernière intervention
11 juillet 2019
19
Ca m'apprendra a faire des copier coller ^^, merci beaucoup !
spylller
Messages postés
390
Date d'inscription
dimanche 1 mars 2015
Statut
Membre
Dernière intervention
11 juillet 2019
19 > spylller
Messages postés
390
Date d'inscription
dimanche 1 mars 2015
Statut
Membre
Dernière intervention
11 juillet 2019

Voilà j'ai changé ça marche, encore merci ^^
Grandasse_
Messages postés
855
Date d'inscription
jeudi 28 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2018
295
My bad !
Effectivement, je vous laisse "couler" ma réponse :)
Messages postés
855
Date d'inscription
jeudi 28 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2018
295
Bonjour,

Tu utilises une balise
form
avec l'attribut
method="post"
.

A aucun moment dans ton "fichier qui reçoit" on retrouve la variable
$_POST['file']
qui récupère les données.

Tu devrais te renseigner là dessus :)

Grandasse