Rechercher dans une autre feuille [Résolu/Fermé]

Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
- - Dernière réponse : Mike-31
Messages postés
16979
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 novembre 2019
- 4 août 2016 à 16:42
Bonjour mes amis,
voila la formule que je utilise pour chercher valeur dans une autre feuille:

=+RECHERCHEV(A1;Feuil2!$A:$D;4;0)
exemple: si je cherche : la valeur de A1= Avril dans la feuille 2 et il le trouve ex dans A1 la formule va me donner la valeur qui lui correspond dans le D1,

le problème que j'ai, si si la valeur rechercher n'a pas trouvé, je recois un MSG de type : #N/A

je veux une méthode meme la valeur introuvable je recois 0 ou lieu de #N/A

Merci infiniment mes chèrs amis


Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
16979
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 novembre 2019
3673
1
Merci
Bonjour,

tout dépend de ta version d'Excel, depuis 2007 tu deux utiliser cette formule
=sierreur(RECHERCHEV(A1;Feuil2!$A:$D;4;0);"")
ou
=sierreur(RECHERCHEV(A1;Feuil2!$A:$D;4;0);0)
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 71486 internautes nous ont dit merci ce mois-ci