Chercher un mot dans une cellule [Résolu/Fermé]

Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
- - Dernière réponse : nonossov
Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
- 26 juil. 2016 à 12:09
Bonjour Mes amis,

j'ai besoin de votre aide à trouver un mot dans une cellule et de donner la valeur qui lui corespondante ; par exemple la cellule A1 contient les mots Smart vision technologie, et dans la cellule B1 contient 100,

je veux savoir la formule que je peux utiliser pour chercher le mot vision dans A1 et de me donner la valeur corespondante.

pour information j'ai utilisé cette formule pour savoir la valuer corresponadte d'un seul mot maintenant j'ai besoin de trouver un mot dans une phrase par excemple.

=+RECHERCHEV(A1;Feuil2!$A:$B;2;0)

merci d'avance mes amis!


Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
41
Date d'inscription
lundi 11 juillet 2016
Statut
Membre
Dernière intervention
8 septembre 2017
12
5
Merci
Salut,

Tu peux faire ca :
=SI(NB.SI(A1;"*vision*");B1;"")

Dire « Merci » 5

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62749 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
-
Bonjour Mr,
Oui cette formule peut me servir, mais est ce qu'on peut cherche un mot sans l'ecrire dans la formule: Par exemple dans la meme formule:

=SI(NB.SI(A1;"A2");B1;"")
on chercher le mot écrit dans A2 ou lieu de l'ecrire dans la formule??

Merci infiniment
Unombre
Messages postés
41
Date d'inscription
lundi 11 juillet 2016
Statut
Membre
Dernière intervention
8 septembre 2017
12 > nonossov
Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
-
Bien sur, ce sera alors :

=SI(ESTERR(TROUVE(A2;A1));"";B1)


Ça cherche A2 dans A1 si oui, alors B1 sinon rien

Il existe bien d'autre méthode bien évidement, peut être que celle la te correspondra mieux.
nonossov
Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
-
Merci infiniment Mr Unombre!!!
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
450
1
Merci
Bonjour,

=RECHERCHEV("*" & A2 & "*";Feuil2!A:B;2;FAUX)

A+
nonossov
Messages postés
587
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
24 octobre 2019
-
Merci Mr Gyrus!