Menu

Extraire une chaine de caractère d'une cellule [Résolu/Fermé]

-
Bonjour,


Jai plusieurs noms de villes dans ma colonne A, de differents nombre de caractère evidemment. Certains sont précèdé d'un x d'autres d'un y et d'autres d'un z et d'autres non aucune lettre aléatoire devant. Commpent puis-je arriver a n'avoir que le nom des villes sans lettre aléatoire devant dans ma colonne B.

A
xBoston
yChicago
zMinnesota
Détroit
Toronto

Merci


Afficher la suite 

3 réponses

Messages postés
1833
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
30 mai 2018
52
0
Merci
sdb77, Bonsoir.

Pour ce faire:

B1 --> =STXT(A1;2;NBCAR(A1)-1)

S'il vous plaît nous dire si elle a travaillé pour vous.
J'espère avoir aidé.
Jai oublier de mentionner que jai aussi des villes avec aucune lettre aleatoire devant. Donc cette formule ne fonctionne car les villes avec aucune lettre devant perdre leurs premiere lettre du nom.
Utilisateur anonyme > sdb77 -
Quand il y a une lettre aléatoire devant, est-ce forcément
une lettre minuscule, ou est-ce que ça peut être aussi
une lettre majuscule ?
> Utilisateur anonyme -
Aussi pour une raison que j'ignore, lorsque je fais cette formule ma colonne B se fusionne automatiquement avec toutes les autre colonnes a sa droite. Par conséquent je perds toutes mes autres données. Ce qui n'est pas souhaitable.
cest toujours une lettre minuscule.
0
Merci
Bonjour sdb77,

Je te propose de mettre en B1 cette formule :
=DROITE(A1;NBCAR(A1)-1)

Ensuite, recopie cette formule vers le bas.

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊
 
Messages postés
23919
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 mai 2019
5791
0
Merci
Bonjour

voici une formule qui fera l'affaire, sauf pour les villes dont les noms commencent par X,Y,ou Z car la Excel, dans tous les cas, ne saura pas faire la différence
=SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"X";"";1);"Y";"";1);"Z";"";1)

annule la première lettre si elle est X,Y,Z

ou encore (mais même problème)

=SI(OU(GAUCHE(A1;1)="X";GAUCHE(A1;1)="Y";GAUCHE(A1;1)="Z");DROITE(A1;NB.CAR(A1)-1;A1))

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
merci beaucoup, c'est un grand pas de fait, ça enlève la lettre aléatoire devant, cependant pour une raison que j'ignores. Les villes dont le nom se termine par un 'x' 'y' 'z' perdent leur dernière lettre aussi. exemple Phoenix devient Phoeni!!
Aussi la 2 e formule me renvoies que j'ai trop d'argument??
Vaucluse
Messages postés
23919
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 mai 2019
5791 -
évidemment, j'aurais du m'en douter, SUBSTITUE....;1) change en "rien" la première valeur trouvée qu'elle soit au début au milieu ou à la fin
pour régler le problème, écrivez:

=SI(OU(GAUCHE(A1;1)="X";GAUCHE(A1;1)="Y";GAUCHE(A1;1)="Z");SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"X";"";1);"Y";"";1);"Z";"";1);A1).

et la deuxième aurait éviter le problème si je l'avais présentée correctement:

=SI(OU(GAUCHE(A1;1)="X";GAUCHE(A1;1)="Y";GAUCHE(A1;1)="Z");DROITE(A1;NBCAR(A1)-1);A1)

restera le problème des noms qui commencent par X Y Z normalement.Là je n'ain pas de solution

excuses, donc et bonne journée
crdlmnt
merci beaucoup!! :) heureusement je n'ai aucune villes commençant par XYZ dans mes options!! :)