OpenVPN s/ Raspberry - problème cer/key - Passerelle par default [Résolu/Fermé]

Signaler
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
-
Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
-
Bonjour,

Je suis en train de me configurer plusieurs raspberry, et je rencontre des problèmes divers.

Actuellement, mon problème est la création du certificat.

J'ai suivis le tuto
http://pazpop.fr/installer-un-serveur-vpn-openvpn-sous-gnulinux-debian/

Il y a notemment une correction importante lié à 2015 au sujet des répertoires.

Lorsque je lance la commande:
cd /etc/openvpn/easy-rsa/
source vars
./clean-all
./build-dh
./pkitool --initca
./pkitool --server server
openvpn --genkey --secret keys/ta.key


Celle-ci doit me créer plusieurs fichiers. Mais ca.crt, ta.key, server.crt, server.key, dh1024.pem ne sont pas générer.

L'erreur est la suivante : string is too long, it needs to be less than 2 bytes long
problems making Certificate Request


J'ai testé plusieurs fois l'opération, mais rien n'y fait.

Si une personne peut m'aider ?
Merci d'avance.

Aider mon prochain comme on m'a aidé... / google = 95% des solutions, mais vous le saviez!
~¨¨¨¨~''°º^v^^v^-= Faites l'amour et pas la guerre ! =-^v^^v^º°''~¨¨¨¨~

1 réponse

Messages postés
128
Date d'inscription
jeudi 27 août 2015
Statut
Membre
Dernière intervention
6 novembre 2016
48
Je te propose éventuellement ce tuto qui est un peu plus détaillé : http://open-freax.fr/monter-vpn-openvpn/
Au moment d'éditer vars, ton tuto n'indique pas qu'il faut modifier " export EASY_RSA="`pwd`" " vers " export EASY_RSA="/etc/openvpn/easy-rsa" "
keviiin_38
Messages postés
128
Date d'inscription
jeudi 27 août 2015
Statut
Membre
Dernière intervention
6 novembre 2016
48 > Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017

Moi j'ai reussi a mettre le mien en place, mais pas d'acces internet, probleme de DNS je pense
Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
464 > keviiin_38
Messages postés
128
Date d'inscription
jeudi 27 août 2015
Statut
Membre
Dernière intervention
6 novembre 2016

Hello,
J'ai suivi un premier tuto de opensource, mais il y a eu une erreur.
J'ai lu ton tuto, qui est super, et je vais recommencer ma config.
A vrai dire, c'est hard.
Pour ton soucis, as-tu bien décommenté la ligne net.ipv4.ip_forward=1 dans /etc/sysctl.conf ?
A bientôt
Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
464
Petit à petit...
Maintenent j'ai ceci comme erreur.
Quelqu'un a une idée... ?

Tue Jul 05 21:06:32 2016 OpenVPN 2.3.10 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Jan  4 2016
Tue Jul 05 21:06:32 2016 Windows version 6.2 (Windows 8 or greater)
Tue Jul 05 21:06:32 2016 library versions: OpenSSL 1.0.1q 3 Dec 2015, LZO 2.09
Tue Jul 05 21:06:32 2016 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Tue Jul 05 21:06:32 2016 Need hold release from management interface, waiting...
Tue Jul 05 21:06:33 2016 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Tue Jul 05 21:06:33 2016 MANAGEMENT: CMD 'state on'
Tue Jul 05 21:06:33 2016 MANAGEMENT: CMD 'log all on'
Tue Jul 05 21:06:33 2016 MANAGEMENT: CMD 'hold off'
Tue Jul 05 21:06:33 2016 MANAGEMENT: CMD 'hold release'
Tue Jul 05 21:06:33 2016 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Tue Jul 05 21:06:33 2016 Control Channel Authentication: using 'ta.key' as a OpenVPN static key file
Tue Jul 05 21:06:33 2016 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jul 05 21:06:33 2016 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Jul 05 21:06:33 2016 Socket Buffers: R=[65536->65536] S=[65536->65536]
Tue Jul 05 21:06:33 2016 Attempting to establish TCP connection with [AF_INET]10.25.13.183:443 [nonblock]
Tue Jul 05 21:06:33 2016 MANAGEMENT: >STATE:1467745593,TCP_CONNECT,,,
Tue Jul 05 21:06:43 2016 TCP: connect to [AF_INET]10.25.13.183:443 failed, will try again in 5 seconds: Le système a tenté de joindre un lecteur à un répertoire stocké sur un lecteur joint.
Tue Jul 05 21:06:48 2016 MANAGEMENT: >STATE:1467745608,TCP_CONNECT,,,
Tue Jul 05 21:06:58 2016 TCP: connect to [AF_INET]10.25.13.183:443 failed, will try again in 5 seconds: Le système a tenté de joindre un lecteur à un répertoire stocké sur un lecteur joint.
Tue Jul 05 21:07:03 2016 MANAGEMENT: >STATE:1467745623,TCP_CONNECT,,,
Tue Jul 05 21:07:13 2016 TCP: connect to [AF_INET]10.25.13.183:443 failed, will try again in 5 seconds: Le système a tenté de joindre un lecteur à un répertoire stocké sur un lecteur joint.
Tue Jul 05 21:07:18 2016 MANAGEMENT: >STATE:1467745638,TCP_CONNECT,,,

Merci d'avance
Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
464 > Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017

Re Bonjour,
Quelqu'un peut-il m'aider pour la passerelle par défaut ?
Raspberry connecté en directe sur internet, pas de routeur.
Authentification fort sur tous les comptes.
Le VPN par OpenVPN s'établit, mais pas d'accès à internet, problème de gateway.
Qui a une idée, j'ai déjà testé plusieurs lignes de code sans succès.
Merci d'avance.
Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017
464 > Gouril
Messages postés
3493
Date d'inscription
samedi 29 octobre 2005
Statut
Contributeur
Dernière intervention
2 février 2017

problème de passerelle résolue.
La fonction OpenVPN est donc à 100% résolue.