Incrémentation automatique excel [Résolu/Fermé]

- - Dernière réponse :  cécile - 28 avril 2016 à 15:03
Bonjour,

Je souhaiterai incrémenter des cellules automatiquement en fonction d'un groupe.
exemple:
si dans A1 est entrée "imprimante", je souhaiterai qu'en B1 s'incrémente automatiquement la référence "IMP1"...
Si dans A2 est entrée "armoire", je souhaiterai qu'en B2 s'incrémente automatiquement la référence "ARM1"...
Si dans A3 est entrée "imprimante", je souhaiterai qu'en B3 s'incrémente automatiquement la référence "IMP2".

merci de votre aide...

Cécile



Afficher la suite 

1 réponse

Messages postés
15915
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 septembre 2019
2794
0
Merci
Bonjour Cécile

en B1
=SI(A1<>"";MAJUSCULE(GAUCHE(A1;3)&NB.SI(A$1:A1;A1));"")

à tirer vers le bas
michel_m
Messages postés
15915
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 septembre 2019
2794 > cécile -
OK, c'est clair

mais:

une autre option pourrait une seule fiche produit avec une liste déroulante peut -^tre plus rapide à manipuler pour l'utilisateur et rendant plus léger le poids du classeur malgré le format binaire

que faut il mettre dans l'entete ?

apparemment des formules "recherchev" et/ou equiv-index devraient suffire
pour être honnête et vous avez dû le comprendre...je suis pas très douée avec les formules. est ce que vous pouvez me dire comment se gère la formule "recherchev"?
si vous dires que c'est plus rapide et léger pour le fichier, je veux bien procéder ainsi.

Merci
michel_m
Messages postés
15915
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 septembre 2019
2794 > cécile -
ci joint un premier jet feuille maquette sans souci de présentation

la ref " référence baba" est une liste à validation de données et la base de la fiche produit car unique ---> une fiche au lieu de n+p+q+1 fiches
2 formules utilisées:
index-equiv pour la désignation

recherchev pour les autres

sur la feuille "liste" les numéros provisoires en bleu ligne 1 sont pour repérer la donnée à retransmettre
par exemple
=RECHERCHEV(E5;tablo;6;0)
6 donne la donnée dans la colonne G


normalement, tu devrais pouvoir construire ta fiche unique
tuto sur rechercheV
http://www.commentcamarche.net/faq/24720-fonction-recherchev-sur-excel

a toi de voir pour la présentation

http://www.cjoint.com/c/FDCkzIQRTlt
> michel_m
Messages postés
15915
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 septembre 2019
-
merci Michel. je vais regarder tout ça...
te tiens au courant du résultat...
> michel_m
Messages postés
15915
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 septembre 2019
-
Michel, mille merci....
j'ai réussi!!!!
effectivement c'est très rapide une fois qu'on rentre toutes les formules!

vous êtes top.
cécile