Remplir une cellule (texte) en fonction d'une autre (texte). [Résolu/Fermé]

Messages postés
28
Date d'inscription
mardi 15 mars 2016
Statut
Membre
Dernière intervention
1 août 2016
-
Bonjour à tous,

Je vais encore vous embêter aujourd'hui avec mon registre/rapport.

Ma question est simple (enfin je crois).
J'ai une liste de client :
- Autocars truc
- Bidule Autocars
- ... etc

J'ai une adresse pour chaque client (sous forme de liste) :
- Pont de Ernest
- Chemin Départemental 6
- ... etc

J'ai un code poste pour chaque client (sous forme de liste) :
- 99548
- ... etc

Ma question est : Si en D18 je récupère l'information du nom de mon client, je veux en D19 son adresse, en E20 son code postal et en M20 sa ville en fonction des listes d'adresse, de code postaux et de villes.
La liste des clients est sur la droite du tableau.

http://www.cjoint.com/c/FDgjIfxjkKu


Afficher la suite 

1 réponse

Messages postés
2497
Date d'inscription
mercredi 11 février 2009
Statut
Membre
Dernière intervention
11 octobre 2019
109
0
Merci
Est-ce que la fonction RECHERCHEV() ne résoudrait pas ton problème ?
SOMUM
Messages postés
28
Date d'inscription
mardi 15 mars 2016
Statut
Membre
Dernière intervention
1 août 2016
-
C'est une piste, je vais chercher :)

ps : je débute excel !
Arkana0
Messages postés
2497
Date d'inscription
mercredi 11 février 2009
Statut
Membre
Dernière intervention
11 octobre 2019
109 > SOMUM
Messages postés
28
Date d'inscription
mardi 15 mars 2016
Statut
Membre
Dernière intervention
1 août 2016
-
OK, alors je vais aller un peu plus loin dans ma réponse :

Avec un tableau dont les colonnes sont organisées dans l'ordre suivant :
Nom du client, adresse, code postal, ville

En tapant en D19 :
= RECHERCHEV(D18;Les cases du tableau défini ci-dessus;2;FAUX)

Cela renverra l'adresse du client renseigné en D18. Pour avoir le code postal et la ville, il suffit de remplacer le 2 respectivement par 3 ou 4. 1 renvoie le nom du client.

Quelques règles de base :
- Il faut que le nom de client soit la première colonne du tableau dans lequel tu vas faire ta RECHERCHEV(), toutes les valeurs renseignées dans les colonnes d'avant ne seront pas accessibles.

- Attention à bien renseigner l'intégralité du tableau où tu veux appliquer ta RECHERCHEV(), si tu rentrais 5 dans mon exemple, tu aurais une erreur #REF

- Attention à bien renseigner "FAUX" à la fin de la formule, autrement la recherche V pourra renvoyer les infos de M. MARTIN au lieu de M. MARTON (valeur proche)

- Pour que cela marche bien, il faut que chaque client soit unique. Si tu as deux Jean MARTIN, la fonction ne renverra que les infos du 1er qu'elle trouvera dans la liste.
SOMUM
Messages postés
28
Date d'inscription
mardi 15 mars 2016
Statut
Membre
Dernière intervention
1 août 2016
-
CA MARCHE !! (même si j'ai eu du mal) Youpiii !