Menu

Vous avez tapé un nombre trop important d'argument [Résolu/Fermé]

- - Dernière réponse :  HAMMA - 18 mars 2016 à 12:11
Bonjour,

S'il vous plaît venez moi en aide, je n'arrive pas a finaliser cette fonction:


=SI(D14<62000;0;SI(D14<310000;(D14*70%-D14*4,2%-41667)*10%);SI(D14<429000;(16231+(D14-310000)*70%*15%);SI(D14<667000;28726+(D14-429000*70%*25%);SI(D14<667000;(28726+(D14-429000)*70%*25%));(70376+(D14-667000)*70%*35%))

Merci d'avance!
Afficher la suite 

3 réponses

Messages postés
24089
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
4630
0
Merci
Bonjour

trop de parenthèses dans la formule et pas assez à la fin:
=SI(D14<62000;0;SI(D14<310000;(D14*70%-D14*4,2%-41667)*10%;SI(D14<429000;16231+(D14-310000)*70%*15%;SI(D14<667000;28726+(D14-429000)*70%*25%;SI(D14<667000;28726+(D14-429000)*70%*25%;70376+(D14-667000)*70%*35%)))))

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Merci
Désolé, c'est plutôt celle-ci

=SI(D14<62000;0;SI(D14<310000;(D14*70%-D14*4,2%-41667)*10%);SI(D14<429000;(16231+(D14-310000)*70%*15%));SI(D14<667000;(28726+(D14-429000)*70%*25%));(70376+(D14-667000)*70%*35%))
Vaucluse
Messages postés
24089
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
4630 -
voyez ma proposition au dessus
Messages postés
9003
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 juin 2019
1583
0
Merci
Bonjour

Essaies ceci
=SI(D14<62000;0;SI(D14<310000;(D14*70%-D14*4,2%-41667)*10%;SI(D14<429000;(16231+(D14-310000)*70%*15%);SI(D14<667000;28726+(D14-429000*70%*25%);(70376+(D14-667000)*70%*35%)))))

Cdlmnt
Merci beaucoup ça marche.

Vous êtes des génies.
ccm81
Messages postés
9003
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 juin 2019
1583 -
Regarde la dernière formule, je l'ai modifié à 11h36

Pour ce genbre de problème tu peux réécrire ta fonction en indentant les si alors sinon
ce qui donne pour ta formule

=SI(D14<62000
;0
;SI(D14<310000
;(D14*70%-D14*4,2%-41667)*10%
;SI(D14<429000
;(16231+(D14-310000)*70%*15%)
;SI(D14<667000
;28726+(D14-429000*70%*25%)
;(70376+(D14-667000)*70%*35%)
))))

Cdlmnt
Merci encore ccm81!