Menu

Calcul Conditionnel [Résolu/Fermé]

Messages postés
44
Date d'inscription
lundi 20 octobre 2014
Statut
Membre
Dernière intervention
9 janvier 2019
- - Dernière réponse : ELPREZZ
Messages postés
44
Date d'inscription
lundi 20 octobre 2014
Statut
Membre
Dernière intervention
9 janvier 2019
- 7 mars 2016 à 12:20
Bonjour,


Si ma case A1 est égale à "Au délà des attentes" alors ma case A2 doit faire le calcul 100% de 500

Si ma case A1 est égale à "Satisfaisant" alors ma case A2 doit faire le calcul 80% de 500

Si ma case A1 est égale à "Conforme" alors ma case A2 doit faire le calcul 60% de 500

Si ma case A1 est égale à "A améliorer" alors ma case A2 doit faire le calcul 20% de 500



D'avance merci de votre aide,



Afficher la suite 

5 réponses

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
10
0
Merci
Bjr, essayez en A2 :

=SI(A1="Au délà des attentes";500*1;SI(A1="Satisfaisant";500*0,8;SI(A1="Conforme";500*0,6;SI(A1="A améliorer";500*0,2;"?"))))


Cdt,
Messages postés
44
Date d'inscription
lundi 20 octobre 2014
Statut
Membre
Dernière intervention
9 janvier 2019
2
0
Merci
Merci de ton aide Theo.R mais j'ai ce message d'erreur

"Etes vous en train de taper une formule ?
Lorsque le premier caractère est un signe égale (=) ou moins (-), Excel considère qu'il s'agit d'une formule :
  • vous tapez : =1+1, la cellule affiche : 2


Pour résoudre ce problème, tapez une apostrophe (") en première place :
  • vous tapez : =1+1, la cellule affiche : =1+1
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1001
0
Merci
Bonjour

La réponse de Theo.R est une formule ,donc il te faut taper le signe =
Cordialement
Messages postés
44
Date d'inscription
lundi 20 octobre 2014
Statut
Membre
Dernière intervention
9 janvier 2019
2
0
Merci
Bonjour jc80 et merci de ton aide mais j'ai tapé le signe = comme indiqué dans la réponse de Théo et j'ai toujour le message d'erreur.

Voici exactement ce que j'ai renseigné et adapté en cellule E17

=SI(C17="Au délà des attentes";500*1;SI(C17="Satisfaisant";500*0,8;SI(C17="Conforme";500*0,6;SI(C17="A améliorer";500*0,2;"?"))))


Je suis désolé mais je ne comprends pas
Vaucluse
Messages postés
24069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2019
4623 -
Bonjour
la formule est correcte, et doit bien commencer avec le signe =
votre Excel doit avoir des problèmes qu'on ne s'explique pas.
Vérifiez quand même à toues fins utiles que le format de cellule soit bien "standard".. ça n'explique pas, mais on ne sait jamais.

on peut toutefois faire un petit peu plus court:
=500*SI(C17="Au délà des attentes";1;SI(C17="Satisfaisant";0,8;SI(C17="Conforme";0,6;SI(C17="A améliorer";0,2;"?"))))

crdlmnt
jc80
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1001 -
Essaies cela

=SI(C17="";"";SI(C17="au dela des attentes";SOMME(500*1);SI(C17="satisfaisant";SOMME(500*0.8);SI(C17="conforme";SOMME(500*0.6);SOMME(500*0.2)))))
Messages postés
44
Date d'inscription
lundi 20 octobre 2014
Statut
Membre
Dernière intervention
9 janvier 2019
2
0
Merci
Bonjour,

Un grand merci à tous,

L'erreur était la , pour 0.8 au lieu du .

A bientot