Remplacer des chaines de caracteres excel [Résolu/Fermé]

Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
- - Dernière réponse : rman13
Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
- 4 mars 2016 à 06:57
Bonjour,

J'ai les noms de cellules suivants:
U_67HA_6
U_67HANordEst_6
U_67HAambala_6


Je voudrais remplacer le dernier _6 par _2 ....

Comment se faire? (qu'est ce qu'il faut taper dans la zone Rechercher de l'onglet Remplacer du menu Rechercher et remplacer)
Merci



Afficher la suite 

1 réponse

Messages postés
8649
Date d'inscription
lundi 21 décembre 2015
Statut
Membre
Dernière intervention
6 juillet 2019
363
0
Merci
Bonjour,

Tu mets un espace à la fin de chaque ligne.
Puis "_6 " remplacer par, ce que tu veux en mettant bien un espace à la fin.
rman13
Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
-
je rappelle que c'est juste un extrait de ma feuille qui contient 2000 lignes au moins...
Donc rajouter un espace à chaque ligne va prendre beaucoup de temps
Merci
> rman13
Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
-
Solution avec une formule

=SI(DROITE(A1;2)="_6";GAUCHE(A1;NBCAR(A1)-2) & "_2";A1)

Tu te mets dans une colonne vide et tu colles la formule en adaptant la cellule source.
Ici j'ai mis A1.

Ensuite copies la cellule destination (qui contient la formule) sur toute la colonne.
Pour terminer, tu copies toute la colonne dans une autre colonne avec l'option valeur.

Tu peux ensuite supprimer la colonne avec les formules.

A+
rman13
Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
> Mosca -
merci Mosca
ça m'a aidé
rman13
Messages postés
35
Date d'inscription
jeudi 3 mars 2016
Statut
Membre
Dernière intervention
10 avril 2018
> Mosca -
Bonjour!!!
c'est réussi