Renvoyer le contenu d'une cellule d'une autre feuille [Résolu/Fermé]

- - Dernière réponse :  Lesmolt - 26 janv. 2016 à 16:42
Bonjour,

J'explicite:
J'ai deux feuilles dans un même classeur, une appelée BD1 et l'autre BD2.

Je veux a partir de la feuille BD2 entrer un chiffre X (par ex 26) en cellule A1 et renvoyer en B1 de la même feuille la valeur (texte ou chiffre) de la cellule FX (ex F26) de la feuille BD1.
J'ai travaillé autour de =indirect mais je tourne en rond sans trouver le moyen de faire référence à la feuille BD1.
D'avance merci
Afficher la suite 

2 réponses

Messages postés
2577
Date d'inscription
mercredi 11 février 2009
Statut
Membre
Dernière intervention
21 novembre 2019
112
0
Merci
Bonjour,

Visiblement, il te faut utiliser la fonction RECHERCHEV(Valeur cherchée, tablea matrice, colonne de la table matrice dont tu veux récupérer la valeur, recherche d'une valeur proche ?)

Tu devrais avoir en B1 de ta feuille BD2 une formule qui a cette allure :
=RECHERCHEV(A1;BD1!E:F;2;FAUX)


Pour que cela marche, il faut :
- Que dans la feuille BD1 tu aies une colonne de valeurs correspondant à ce que tu as en colonne A de la feuille BD2.
- Que cette colonne se situe avant celle dont tu veux récupérer les données.
- Que pour chaque valeur différente possible dans ta colonne A, tu n'aies qu'un résultat possible à trouver. Autrement la fonction renverra le premier qu'elle trouve en négligeant complètement le reste.
- Indiquer le bon numéro de colonne. La première colonne de ta sélection (ici la colonne E de BD1) est la numéro 1. Si c'était la colonne A et que tu veux toujours la colonne F, ce serait 6.
- Toujours rentrer FAUX dans le dernier argument de la formule. Autrement en cherchant "aaaaa", si la formule tombe sur "aaaab", elle te renverra la valeur correspondant à aaaab car c'est "proche de ce qu'il faut chercher".

C'est un peu compliqué d'expliquer ça simplement, je te conseille de l'expérimenter.
J'y avait pensé mais en fait j'ai plusieurs ligne identique a l'origine sur plusieurs critères seule une valeur change sur une colonne
Je voudrais juste qu'en saisissant dans la cellule A1 de la feuille BD2 la valeur "2" par exemple il remonte la valeur "XXXX" de la cellule D2 de B1.
En fait le je voudrai une formule dans laquelle la référence de la cellule D serait fixe et le chiffre que le collègue saisissent définisse la ligne la cellule exacte.
Mais cela parait difficile....
Merci.
Arkana0
Messages postés
2577
Date d'inscription
mercredi 11 février 2009
Statut
Membre
Dernière intervention
21 novembre 2019
112 -
Dans ce cas, il faudrait travailler avec la fonction INDEX(), le soucis c'est que je ne la maîtrise pas vraiment.
Oui c'est assez difficile. Merci a toi j'a abandonné en ajoutant la colonne numérotée de 1 a x et j'ai fait des recherchev comme tu le suggérais. Merci a toi.
eriiic
Messages postés
23083
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 novembre 2019
5761 -
Merci poue votre aide a tous.
Messages postés
23083
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 novembre 2019
5761
0
Merci
Bonjour,

=DECALER(Feuil1!$F$1;A1-1;)
Une cellule vide retourne 0, ajouter un test si gênant.
eric