Menu

Référence onglet autre fichier en fonction valeur d'une cellule [Résolu/Fermé]

- - Dernière réponse : Vaucluse
Messages postés
24206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juillet 2019
- 28 nov. 2015 à 13:30
Bonjour,

Je cherche la syntaxe pour définir une plage dans un autre fichier sur un onglet où le nom de l'onglet est défini en fonction de la valeur d'une cellule.
Ex :

A1 = nom de l'onglet
A2 = NB.SI('[classeur1.xlsx]Feuil1'!$A$1:$B$10,F10)>0

Je cherche à remplacer Feuil1 par la valeur de la cellule A1 mais sans succès.

merci d'avance de votre aide!


Afficher la suite 

2 réponses

Messages postés
24206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juillet 2019
4681
0
Merci
Bonjour

= NB.SI(INDIRECT("'[classeur1.xlsx]"&A1&"'!$A$1:$B$10"),F10)>0
attention aux signes

crdlmnt
0
Merci
Merci de votre réponse. Par contre j'ai comme réponse #réf. Je pense que j'ai fait une erreur de syntaxe avec les signes...
Pouvez vous me dire si vous voyer quelque chose?

=SI(NB.SI(INDIRECT("'[Radar charts all pillar leaders nov 2015 - last version - vierge.xlsx]"&C39&"'!$D$1:$F$360"),F10)>0,1,0)

Cordialement
Vaucluse
Messages postés
24206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juillet 2019
4681 -
vois rien de spécial si le nom de feuille est bien en C39, mais il faut que le classeur source soit ouvert, est ce le cas?
C'est bon j'ai réussi! Merci beaucoup! Par contre je n'ai pas compris où était mon erreur...
Vaucluse
Messages postés
24206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juillet 2019
4681 -
Probablement une faute de frappe , ou une virgule au mauvais endroit, un fichier fermé", va savoir!?
L'essentiel étant que ça fonctionne comme vous le souhaitez
je passe le sujet en résolu
Bonne route
crdlmnt