Récupérer valeur [Fermé]

Signaler
Messages postés
557
Date d'inscription
samedi 3 mars 2012
Statut
Membre
Dernière intervention
10 septembre 2015
-
@mesam
Messages postés
557
Date d'inscription
samedi 3 mars 2012
Statut
Membre
Dernière intervention
10 septembre 2015
-
Bonjour,

Je cherche à récupérer une valeur dans une autre feuille.

Exemple :

Feuille1

Valeur à récupérer avec formule en B1 qu'il faudra glisser pour les autres cellules.
En B1 je veux afficher 123000 de la feuille deux


Feuille 2
Valeur à récupérer en colonne B en recherchant la valeur identique à la feuille 1 en colonne A


Merci.

4 réponses

Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020
1 672
Bonsoir

Il faut utiliser RECHERCHEV

en B1 :
=RECHERCHEV(A1;Feuil2!A:B;2;0)

A étirer ensuite

Cdlmnt
Via
Messages postés
557
Date d'inscription
samedi 3 mars 2012
Statut
Membre
Dernière intervention
10 septembre 2015
22
Merci pour cette réponse.

Cela m'affiche un 0 en résultat ?

la formule ->
=RECHERCHEV(A1;Feuil2!A:B;2;0)



Si j'ai compris :

A1
-> Cellule à comparer
Feuil2 -> Feuille de recherche
! -> Ça je ne sais pas
A:B -> Les colonnes ou chercher les valeurs
2;0 -> Je ne saispas

Ah oui je pensais aussi que ça pouvais venir de l'espace 10533 et 10 533
Mais non car j'ai testé mais idem ?
D'ailleurs cette espace dans Feil2 ne pausera pas de soucis ?
Si oui embêtant car la liste est longue :)

Merci.

PS j'ai essayé ceci mais idem !
=RECHERCHEV(A1;Feuil2!A:A:B:B;2;0)
Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020
1 672
Oui si les termes ne sont pas identiques entre la feuil1 et la 2 la formule ne trouvera pas de correspondance, surtout si il y a mélange de texte et de nombre
le 2 est le séparateur normal entre le nom d'une feuille et la plage (si ta Feuil2 a un autre nom il faut bien sûr remplacer Feuil2 par ce nom dans la formule)
2 la colonne dans la plage de recherche où se trouvent les valeurs à renvoyer
0 recherche d'une correspondance exacte

Si malgré tout ça ne marche pas postes ton fichier sur cjoint.com, fais créer un lien, copies-le et reviens l'indiquer ici, je regarderai ce qui cloche

Cdlmnt
Via
Messages postés
557
Date d'inscription
samedi 3 mars 2012
Statut
Membre
Dernière intervention
10 septembre 2015
22
Bon du coup je ne pige plus !
cela fait un moment que je creuse :)

J'ai supprimé la formule et ressaisie et j'ai la première valeur.
Surement une erreur qui bloque tout ça.

Merci pour tout.

mp envoyé ;-)