Excel - Problème inscription formule VBA - NB.JOURS.OUVRES() [Résolu/Fermé]

-
Bonjour à tous,


Cela fait mtn plusieurs jours que je m'arrache les cheveux sur quelque chose qui me parait, en soit, pas compliqué :

J'ai un tableau excel sur lequel je creer des onglets et veux inscrire des formules excel à l'intérieur de certaines cellules. Je veux que tout ceci soit géré dans mon code VBA.

La formule qui me pose problème est une avec le calcul de jour ouvrés entre deux dates :

J'ai beau essayer avec FormulaLocal, Formula ou rien du tout, j'ai à chaque fois une erreur 1004.


Range("M7").Select
ActiveCell.Formula = "=IF(H7<>"",0,IF(G7<>"",NETWORKDAYS($B$1,G7),""))"


ou

ActiveCell.FormulaLocal = "=SI(H7<>"";0;SI(G7<>"";NB.JOURS.OUVRES($B$1;G7);""))"



La formule excel marche, mais sur VBA ne veut pas me l'inscrire dans mon tableur :/

Merci d'avance à tous si vous pouvez vous penchez sur mon problème !

Afficher la suite 

3 réponses

0
Merci
Je me permet de préciser que mon code est dans une sub dans un module et que j'appelle le sub dans du code inscrit dans ThisWorkbook (range("M7") renvoi toujours à quelque chose)
Messages postés
23074
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
5755
0
Merci
Bonjour,

vu qu'il s'agit d'une fonction d'une macro complémentaire je ne suis pas sûr que tu puisses mettre la fonction par macro, éventuellement son résultat calculé par macro est faisable.

Par contre tu peux passer par une formule nommée, il n'y a plus que le nom à poser.
Attention à avoir la bonne cellule active lorsque tu crées ton nom si tu as des références relatives dans la formule.
http://www.cjoint.com/c/EHkkqVPBFbA

eric

PS: je viens de voir que tu as mis en résolu, si tu pouvais mettre ta solution que les autres en profite.

En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0
Merci
Merci bcp eriiic !

Je suis en effet passé par une formule nommée et ça fonctionne très bien ! je ne sais pas pourquoi je n'y avais pas pensé... !

Bonne journée,

Sujet Clos