Menu

Comment calculer un chiffre d'affaire par créneau horaire ? [Résolu/Fermé]

-
Bonjour a tous :)


J'ai une base de donnée (date d'achat / heure d'achat / montant d'achat). J'ai besoin d'avoir un visuel sous forme de graphique afin de suivre l'évolution journalière et mensuelle de mon activité.


Pour se faire, j'ai déjà calculé:
- Le total par jour (NB d'article vendu & CA),
- Le total du mois (NB d'article vendu & CA),


J'aimerai aller plus loin et connaitre les pics d'activités par tranche horaire (Entre 10:00 et 11:00 / entre 11:01 et 12:00 / entre 12:01 et 13:00 / etc jusqu'à 20:00)

Exemple:
DATE HEURE Montant panier
01/07/2015 10:23 106,30 €
01/07/2015 10:28 178,05 €
01/07/2015 10:34 232,63 €
01/07/2015 10:39 190,28 €
01/07/2015 10:51 126,16 €
01/07/2015 10:58 379,89 €
01/07/2015 11:07 154,75 €
01/07/2015 11:13 197,41 €
01/07/2015 11:18 101,50 €
01/07/2015 11:24 181,62 €
01/07/2015 11:32 111,34 €



Est-ce que c'est possible? Si oui, comment?


Je vous remercie par avance :)


Afficher la suite 

1 réponse

Messages postés
24210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
0
Merci
Bonjour
faite un tableau avec par exemple à adapter
à partir de ligne 2
laisser X1 vide ou =0
en X2 et suivant, l'heure de fin de la fourchette
en Y2 pour la première tranche donc heure en X2
=SOMME.SI.ENS(C:C;B:B;"<="&X2;B:B;">"&X1)
à tirer sur la hauteur de la liste des heures en X

vous pouvez aussi remplacer SOMME.SI.ENS par MOYENNE.SI.ENSE qui vous donnera la moyenne de la fourchette pour l'horaire pour tous les jours cumulés de la liste

code ....ENS valable à partir de Excel 2007 seulement sinon écrire mais cette fois avec des N° de ligne dans les limites de champ:

=SOMMEPROD(($B$2:$B$1000<=X2)*($B$2:$B$1000>X1)*($C$2:$C$1000))
il ne doit pas y avoir en C autre chose que des valeurs num avec ce code

crdlmnt