Moyenne intervalle [Résolu/Fermé]

Signaler
-
 PeterPanPan -
Bonjour,

j'ai un tableau excel avec 100001 lignes dans la colonne B
je désire faire la moyenne des 1000 premiers points, puis une autres moyennes des 1000 points suivant et ainsi de suite. Sans prendre en compte la première moyenne pour calculer la deuxième.
Mais je ne vois pas comment faire, j'ai utilisé cette formule =MOYENNE(DECALER(B$2:B$100001;(LIGNE()-2)*100;)) mais cela fait la moyenne sur tous les points pour la première valeur.
Merci d'avance.


3 réponses

Messages postés
2292
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
16 janvier 2020
781
Bonjour,
Ou bien en C2
=MOYENNE(DECALER(B$2;(LIGNE()-2)*1000;0;1000;1)) à recopier sur la hauteur voulue.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 87034 internautes nous ont dit merci ce mois-ci


Merci pour ta réponse, peux-tu m'expliquer ce que représente ligne()-2 ?

ça fonctionne parfaitement merci beaucoup !
Messages postés
593
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
42
Bonjour,

Pourquoi ne pas nommer les 1000 premiers points puis les 1000 suivants etc, cela te prendra 2 minutes ...

Puis après :

=moyenne(partie1)
=moyenne(partie2)

Etc...

Cdlt

P.S : après réfléxion, cela te prendra 5 min max

Je veux acquérir des compétences en plus dans le logiciel excel c'est pour cela que je pose la question. Oui je peux faire la moyenne à chaque fois mais c'est rébarbatif et je dois le faire sur 50 fichiers. Je me demandais si on pouvais tout automatisé

Mais merci de ta réponse en tout cas
Messages postés
2292
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
16 janvier 2020
781
Le second argument de la fonction Decaler "(LIGNE()-2)*1000" définit de combien de lignes on décale la référence, ici B2.
En C2 (LIGNE()-2)*1000 =0
En C3 (LIGNE()-2)*1000 =1000
En C4 (LIGNE()-2)*1000= 2000 etc

d'accord tontong merci pour tes explications