Menu

Fonction si entre 2 dates [Fermé]

- - Dernière réponse : Raymond PENTIER
Messages postés
49100
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 juin 2019
- 4 avril 2015 à 19:10
Bonjour,
Je souhaiterais utiliser une fonction Si entre deux dates mais n'arrive pas à un résultat. Voici la formule que j'ai tenté
= SI(ET(B1>=01/07/2014;B1<=30/06/2015);"exercice 2014-2015";"exercice 2013-2014)
En B1 j'ai des cellules avec des dates

Merci de votre aide

Afficher la suite 

2 réponses

Messages postés
10686
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 juin 2019
1306
0
Merci
Bonjour Joe35

Essaie :
= SI(ET(B1>=DATEVAL("1/7/2014");B1<=DATEVAL("30/6/2015"));"exercice 2014-2015";"exercice 2013-2014")

Cdlmnt
Via
Messages postés
49100
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 juin 2019
10031
0
Merci
Bonjour, tous les deux.

Autre méthode, que j'utilise habituellement :
Dans des cellules disponibles je saisis les dates 01/07/2014 et 30/06/2015 et je définis les noms "déb" et "fin" pour ces deux cellules.
Ainsi la formule devient
=SI(ET(B1>=déb;B1<=fin);"exercice 2014-2015";"exercice 2013-2014")
ou encore
="exercice " & SI(ET(B1>=déb;B1<=fin);"2014-2015";"2013-2014")