Menu

Excel - Formule calcul âge de la retraite [Résolu/Fermé]

Messages postés
141
Date d'inscription
jeudi 22 août 2013
Statut
Membre
Dernière intervention
4 septembre 2018
-
Bonjour, je souhaiterais que qqn me vienne en aide j'ai tenté d'écrire une formule pour calculer l'age de la retraite en fonction de la date de naissance, car la date de départ varie en fonction de l'année de naissance :
L'âge minimal pour partir à la retraite est de 62 ans pour les personnes nées à partir du 1er janvier 1955. Pour les générations précédentes, cet âge diffère en fonction de l'année de naissance, selon le tableau suivant :



Date de naissance Age minimum de départ en retraite
Avant le 1er juillet 1951 60 ans
Du 1er juillet au 31 décembre 1951 60 ans et 4 mois
Année 1952 60 ans et 9 mois
Année 1953 61 ans et 2 mois
Année 1954 61 ans et 7 mois
Année 1955 62 ans

J'ai donc écrit la formule ci-dessous pour obtenir dans chaque le dernier jour du mois du départ à la retraite (NE PAS SE SOUCIER DE la particularité de 1951)
En cellule K2 j'ai donc la date de naissance, mais la formule ne focntionne pas et je ne vois quelle est mon erreur, merci par avance à ceux qui vont se pencher sur le problème.

'=SI(ANNEE(K2)=1952;DATE(ANNEE(K2)+60;MOIS(FIN.MOIS(K2;0))+9;JOUR(FIN.MOIS(K2;0)));
SI(ANNEE(K2)=1953;DATE(ANNEE(K2)+61;MOIS(FIN.MOIS(K2;0))+2;JOUR(FIN.MOIS(K2;0)));
SI(ANNEE(K2)=1954;DATE(ANNEE(K2)+61;MOIS(FIN.MOIS(K2;0))+7;JOUR(FIN.MOIS(K2;0)));
SI(ANNEE(K2)>=1955;DATE(ANNEE(K2)+62;MOIS(K2);JOUR(FIN.MOIS(K2;0)));DATE(ANNEE(K2)+60;MOIS(K2);JOUR(FIN.MOIS(K2;0)))))))
Afficher la suite 

6 réponses

0
Merci
Bonjour . Question à poser de préférence ici --->http://droit-finances.commentcamarche.net/ . Cdlt
0
Merci
Heu , pardon , je n'avais pas saisi le sens de cette question , avec mes sincères excuses . cdlt
ec163
Messages postés
141
Date d'inscription
jeudi 22 août 2013
Statut
Membre
Dernière intervention
4 septembre 2018
30 -
Merci de votre commentaire, j'ai revu le sujet pour être plus précis.
Cdlt
ec163
Messages postés
24069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2019
4623
0
Merci
Bonjour
je pense d'une part que votre formule peut être un peu simplifier
sachant que vous pouvez remplacer dans les trois items
MOIS(FIN.MOIS(K2;0))+.... par MOIS(K2)+...
il serait bon aussi de supprimer une des trois parenthèses derrière chaque item "date" et d'en supprimer aussi trois à la fin.
Mais en fait, elle devrait fonctionner.
Que vous renvoie t elle comme résultat?
à vous lire




ec163
Messages postés
141
Date d'inscription
jeudi 22 août 2013
Statut
Membre
Dernière intervention
4 septembre 2018
30 -
le mois et l'année fonctionne correctement c'est le jour qui ne va pas. La formule devrait me renvoyer le dernier jour du mois mais parfois (pas tout le temps ce qui est encore plus chi...) le jour est le 1er du mois suivant ou l'avant dernier du mois.
Vaucluse
Messages postés
24069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2019
4623 > ec163
Messages postés
141
Date d'inscription
jeudi 22 août 2013
Statut
Membre
Dernière intervention
4 septembre 2018
-
Je reprend mon message supprimé suite à erreur de ma part.
le résultat que vous obtenez est normal car la date que vous calculez correspond à un mois qui n'a pas pas forcément le même nombre de jours que le mois de naissance.
Exemple:si vous avez une date de naissance en janvier et que le calcul vous fait tomber en Juin,Excel aura du mal à caser le 31 juin quelque part.
écrivez donc vos dates comme suit:

=FIN.MOIS(DATE(ANNEE(K2)+60;MOIS(K2)+9;1);0)

qui vous donnera bien la date de fin du mois calculé.
crdlmnt
Messages postés
14161
Date d'inscription
samedi 1 septembre 2007
Statut
Membre
Dernière intervention
15 juin 2019
860
0
Merci
bonjour, ça ne répond pas a votre question, mais si vous voulez un simulateur tout fait...
http://www.cfdt-retraités.fr/?page=simulateur14
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
441
0
Merci
Bonjour,

Un exemple de solution
http://cjoint.com/?EBAkVdAm33t

A+
merci bien pour votre réponse
Messages postés
141
Date d'inscription
jeudi 22 août 2013
Statut
Membre
Dernière intervention
4 septembre 2018
30
0
Merci
C'est bon je viens de répondre à mon problème, après qqs recherches et un grand merci à Vaucluse. A force de regarder la formule je ne la voyais plus!!!!!!!! donc j'ai isolé l'année de naissance en colonne K et la colonne L correspond à la date à laquelle la personne aura 60 ans, d'où la formule ci-dessous :
=SI(ANNEE(K2)=1952;FIN.MOIS(DATE(ANNEE(L2);MOIS(L2)+9;JOUR(L2));0);
SI(ANNEE(K2)=1953;FIN.MOIS(DATE(ANNEE(L2);MOIS(L2)+14;JOUR(L2));0);
SI(ANNEE(K2)=1954;FIN.MOIS(DATE(ANNEE(L2);MOIS(L2)+19;JOUR(L2));0);
SI(ANNEE(K2)>=1955;FIN.MOIS(DATE(ANNEE(L2)+2;MOIS(L2);JOUR(L2));0);
FIN.MOIS(DATE(ANNEE(L2);MOIS(L2);JOUR(L2));0))))).
Et la je tombe bien le dernier jour du mois correspondant, YES!!!!!!
Vaucluse
Messages postés
24069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2019
4623 -
OK; alors je passe le sujet en résolu
Bonne route