Formule NB.SI et ajout d'une condition [Résolu/Fermé]

Signaler
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
-
Happy79_2
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
-
Bonjour,

Dans unequestion précédente nous avons statué sur la formule
=NB.SI(J4:J559;1)+NB.SI(J4:J559;"*1,*")+NB.SI(J4:J559;"*, 1")

afin de cumuler une valeur x dans une colonne dans laquelle une cellule peut contenir plus d'une valeur. (ex : 1,2,10,11).

J'ai maintenant besoin que cette formule s'active seulement si, dans ma colonne Q, il y ait une date de fermeture du dossier. Quelque chose comme : Si Q est nonvide, NB.SI(J4:J559;1)+NB.SI(J4:J559;"*1,*")+NB.SI(J4:J559;"*, 1"), mais pour la ligne correspondante.

Il y a probablement un RechercheV à intégrer, mais je n'ai aucune idée comment l'intégrer.

Je n'ai aucun doute que vous trouverez quelque chose.

Merci à l'avance! :)


4 réponses

Messages postés
24768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 janvier 2020
4962
Bonsoir
essayez celle ci:
=SOMMEPROD((NB.SI(J4:J559;1)+NB.SI(J4:J559;"*,1")+NB.SI(J4:J559;"*1,*"))(Q4:Q559=1))
Crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 80249 internautes nous ont dit merci ce mois-ci

Messages postés
11550
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 janvier 2020
1588
Bonsoir

Essaie :
NB.SI.ENS(J4:J559;1;Q4:Q559;"<>""")+NB.SI.ENS(J4:J559;"*1,*";Q4:Q559;"<>""")+NB.SI.ENS(J4:J559;"*, 1";Q4:Q559;"<>""")

Cdlmnt

"L'imagination est plus importante que le savoir." A. Einstein
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
1
Je suis en Excel 2003, je crois que NB.SI.ENS ne marche pas... COde d'erreur #NOM?
via55
Messages postés
11550
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 janvier 2020
1588
Oui NB.SI.ENS utilisable qu'à partir de 2007
Il faut utiliser alors SOMMEPROD
Si tu recherches un 1 nimporte où dans une suite dans la colonne J ta formules peut se résumer alors à cela :
=SOMMEPROD((NON(ESTERREUR(TROUVE("1";J4:J559)))*(Q4:Q559<>"")))

Cdlmnt
Happy79_2
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
1 > via55
Messages postés
11550
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 janvier 2020

J'aurais aimé dire que ça fonctionne, mais le nombre est supérieur à la formule d'origine, soit 47 données vs 45, et devrait en compter 40... Merci pouor l'essai.
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
1
Est-ce qu'il manque un élément à l'endroit souligné et en gras?

=SOMMEPROD((NB.SI(J4:J559;1)+NB.SI(J4:J559;"*,1")+NB.SI(J4:J559;"*1,*"))(Q4:Q559=1))

Excel me propose toujours une correction à la formule, mais la correction ne convient pas. Également, je ne comprend pas pourquoi, dans votre formule, vous mettez Q4:Q559=1 alors que c'est une colonne de date...ça ne devrait pas être plutot <>"" ?

merci de m'éclairer.
Vaucluse
Messages postés
24768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 janvier 2020
4962
Exact, faute de frappe, il faut ajouter * entre les deux items
=SOMMEPROD((NB.SI(J4:J559;1)+NB.SI(J4:J559;"*,1")+NB.SI(J4:J559;"*1,*"))*(Q4:Q559=1))
excuses
crdlmnt
Happy79_2
Messages postés
61
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
4 octobre 2016
1 > Vaucluse
Messages postés
24768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 janvier 2020

YAY! Merci! ça semble parfait!