Comment éviter les "0" en une seule formule [Fermé]

Signaler
Messages postés
53
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014
-
Mike-31
Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
-
Bonjour,

existe t'il UNE SEULE FORMULE pour n'afficher dans l'ordre les nombres de la colonne B SANS UTILISER « Données, puis filtre standard " ou de multiples formules .
L'objectif de la colonne E est d'afficher les séries de « 1 » et le moment ou elles s'interrompent (noté 0) se référant à la colonne B

http://cjoint.com/?DKftJGmuDiB

cordialement
eric

8 réponses

Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3716
Bonjour,

Pour ma part je n'ai rien compris aux explications,

sur ton fichier, colonne B tu as des chiffres, que faut il en faire

ensuite colonne C tu as également des chiffres que faut il en faire

en colonne E que veux tu afficher
Messages postés
53
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014

bonsoir,
je souhaite afficher en col C tous les nombre de B sans les cellules vides (ce que je sais faire uniquement avec le filtre standard.
Mëme chose en E
voici un nouveau fichier
cordialement
eric

http://cjoint.com/?0Kfw1Lc9kqk
Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3716
Re,

Ton fichier est un fichier Open Office, essaye quand même cette formule Excel sans garantie en attendant qu'un adepte de cette application prenne la suite

tu peux tester cette formule matricielle qu'il faudra valider en cliquant en même temps sur les 3 cellules du clavier Ctrl, Shift et Entrée. Si tu fais bien la formule se placera entre {}

=SIERREUR(INDEX($B$1:$B$2500;PETITE.VALEUR(SI($B$1:$B$2500<>"";LIGNE(INDIRECT("1:"&LIGNES($B$1:$B$2500))));LIGNES($1:1)));"")

Ou
=INDEX($B$1:$B$2500;PETITE.VALEUR(SI($B$1:$B$2500<>"";LIGNE(INDIRECT("1:"&LIGNES($B$1:$B$2500))));LIGNES($1:1)))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
53
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014

bonsoir,
merci de ta réponse
la formule =SI(ESTERREUR(INDEX($B$1:$B$2500;PETITE.VALEUR(SI($B$1:$B$2500<>"";LIGNE(INDIRECT("1:"&LIGNES($B$1:$B$2500))));LIGNES(B$1:$B1)));""))
renvoie l'erreur 508
le pb vient de ESTERREUR OU ERREUR qui n'existe pas sur open
l'autre retourne 0
cordialement
eric
Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3716
Re,

Open Office n'a pas les mêmes fonctions ou toutes les les fonctions d'Excel ce qui est normal,
essaye comme cela
=INDEX($B$1:$B$2500;PETITE.VALEUR(SI($B$1:$B$2500<>"";LIGNE(INDIRECT("1:"&LIGNES($B$1:$B$2500))));LIGNES($1:1)))

J'espère pour toi qu'un adepte d'Open prendra la suite
Messages postés
53
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014

bonjour,
la formule renvoie "NOM?" ou 0 en modifiant la formule "lignes"
cordialement

j'installe excel
eric
Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3716
Re,

alors avec excel pas de problème tu peux reprendre mes formules

=SIERREUR(INDEX($B$1:$B$2500;PETITE.VALEUR(SI($B$1:$B$2500<>"";LIGNE(INDIRECT("1:"&LIGNES($B$1:$B$2500))));LIGNES($1:1)));"")